RS/6000 7043-140 boot floppies

Alan Perry aperry at
Mon Feb 18 16:42:27 CST 2019

On 2/18/19 1:55 PM, Tapley, Mark wrote:
>> On Feb 18, 2019, at 11:49 AM, Alan Perry via cctech <cctech at> wrote:
>> Is there some trick to making boot floppies for the RS/6000 7043-140 (a mid-90s PReP architecture machine)?
>> I initially tried to install Solaris 2.5.1 on it and created the boot floppy by dd'ing the image using a SPARCstation (running NetBSD). I dd'ed the image over, dd'ed it back and verified the SPARCstation could read back what it had written to the floppy. The RS/6000 loads what is on the floppy, but hangs transferring control to what it loaded.
>> The 7043-140 does not appear on the list of supported systems in the Solaris 2.5.1 release notes, so, even though 2.5.1 supports PReP and the 7043-140 is a PReP machine, maybe they aren't compatible, so I tried NetBSD. The 7043-140 is listed as a supported system.
>> The NetBSD boot floppy images are confusing to me. The files are too large to fit on a 1.44M floppy. I didn't see instructions on how to make boot floppies out of the .fs files one can download in the install instructions. I went ahead and tried to dd the part that fits onto a 1.44M floppy and try to boot that and of course that failed. I have e-mailed the NetBSD prep mailing list and no response from that.
>> The system does boot the AIX install on one of its hard disks, but this is a recycled system and I don't have usernames/passwords for that install.
>> Does anyone here have a suggestion on how to proceed?
>> alan
>> CAUTION: This email originated from outside SwRI and it may contain attachments and/or links. Do not open attachments or click on links unless you recognize the sender and know the content is safe.
> Alan,
> 	does the machine also have a CD drive? I got a *lot* of help fast from this list last year while resetting root and user passwords on one of those machines by using the first CD of the AIX install set. I guess that won’t help toward solaris but at least you could run AIX.
> 								- Mark
Yes, it has a CD drive. Do you recall what month the discussion was so I 
know where to start looking in the list archive?

It sounds as if Solaris doesn't run on the 604e in the 43p/7043 (I will 
never understand IBM model designations); I just want to make the system 
usable at this point.


More information about the cctalk mailing list