RS/6000 7043-140 boot floppies

Alan Perry aperry at
Mon Feb 18 11:49:30 CST 2019

Is there some trick to making boot floppies for the RS/6000 7043-140 (a 
mid-90s PReP architecture machine)?

I initially tried to install Solaris 2.5.1 on it and created the boot 
floppy by dd'ing the image using a SPARCstation (running NetBSD). I 
dd'ed the image over, dd'ed it back and verified the SPARCstation could 
read back what it had written to the floppy. The RS/6000 loads what is 
on the floppy, but hangs transferring control to what it loaded.

The 7043-140 does not appear on the list of supported systems in the 
Solaris 2.5.1 release notes, so, even though 2.5.1 supports PReP and the 
7043-140 is a PReP machine, maybe they aren't compatible, so I tried 
NetBSD. The 7043-140 is listed as a supported system.

The NetBSD boot floppy images are confusing to me. The files are too 
large to fit on a 1.44M floppy. I didn't see instructions on how to make 
boot floppies out of the .fs files one can download in the install 
instructions. I went ahead and tried to dd the part that fits onto a 
1.44M floppy and try to boot that and of course that failed. I have 
e-mailed the NetBSD prep mailing list and no response from that.

The system does boot the AIX install on one of its hard disks, but this 
is a recycled system and I don't have usernames/passwords for that install.

Does anyone here have a suggestion on how to proceed?


More information about the cctalk mailing list