Restoring a PC Server 500 P/390

Dave Wade dave.g4ugm at
Sun May 13 05:00:37 CDT 2018

> -----Original Message-----
> From: cctalk <cctalk-bounces at> On Behalf Of Grant Taylor via
> cctalk
> Sent: 13 May 2018 00:59
> To: cctalk at
> Subject: Re: Restoring a PC Server 500 P/390
> On 05/12/2018 05:07 PM, Dave Wade via cctalk wrote:
> > I was so unsure of what I was doing that I haven't blogged, twittered,
> > or even Facebooked....
> And here I went and asked you to air dirty laundry.  —  I'm sorry.
> But I am grateful that you did so.  :-)  I did find it an interesting read, and I
> have a few comments that I'll share inline below.

Actually it was good to run through what I had done and write it down. I am a volunteer at the museum of science and industry and when I work there we record everything in a log book. I don't follow the same discipline at home but it would be a good idea.

> > The server just about worked when I got it, but with six 20 year old
> > disks (I think they are twenty) in a flaky RAID array the thing spent
> > more time recovering dropped disks than it did working.  The spin up
> > time is critical, and like me I think these are showing their age and
> > the array controller gets tired of waiting for them to come ready and
> > then the array needs to be checked for consistency. Yuk.
> Ya, I can see how that could be a problem.
> What sort of RAID are they in?  One big six disk RAID 5?  Or is it something
> more exotic?  Striping across three sets of two disk mirrors?
> Is one of them a hot spare?
> How big are each of the disks?
> Are they true SCSI?  Or are they some variant of SCSI that IBM liked to mess
> with in the late '90s through the early '00s?  Serial Storage Architecture (SSA)
> comes to mind.
> If they are standard SCSI, I'd be tempted to hook the drives up to another
> machine, image them, and likely run SpinRite on them.  (Order may depend
> on their current state.)
> I might also be tempted to try to have the drives spin up and stay spinning,
> even if the machine is otherwise off.  An external enclosure with separate
> power would be really nice.  At least that would help the typical physical
> issues that drives tend to have.
> Then, hopefully the drives would be stable and happy enough that you could
> focus on the RAID card.

I have tried to keep the drives spinning but it doesn't' work. The RAID card wants to control the power to the drives. There is info on the RAID card here.

and the server page has pictures of the drive bays here:-

I the day it was a very nice system. There are several IBM letters about mods to the RAID and backplanes and I think they have all been done. There are more notes on how to recover from it marking a drive "defunct" which I have followed to the letter.
I did get it to work once when I managed to IPL MVS on the P390 so I hope the data is still intact, but next time I booted the system we were back to defunct drives so a day or so would be required to recover.

They are real SCSI drives with I think SCA connectors. I think they are "double height" 4gb drives (they are vertical in the machine so double width) giving 40gb for the 6 drive RAID. 

> > I was hoping to get the RAID working and copy the data to elsewhere,
> > and may still try and do that, but for now I have been implementing
> > "Plan B":-
> *nod*
> Is there still original data on the RAID?  Is it just intermittently accessible?
> Just unstable enough that you can't rely on it for playing / learning?

If a drive doesn't spin up quickly enough it marks it DEFUNCT (DDD). If you can get it to spin up it can be brought back on-line BUT this requires a lengthy check procedure which means booting from floppy.

> > 1. Cleaned the floppy drive. It’s a 2.88 and still a little flaky, but
> > it gets used a lot when messing with Microchannel and OS/2. The
> > equivalent of the BIOS config is run from floppy and it needs to be
> > re-run every time you move cards around.
> Yep, I remember the System Reference Disks.  —  I've been messing with a
> Compaq ProLiant that has similar programs, but they reside on a partition on
> the drive.  Making it a little easier to run them.
> > The CDs are not bootable and need at least two floppies to get them
> > loading so more reliance on the FDD.
> *nod*nod*
> My how things have changed.
> > Its not simple to change the drive as IBM "re-purposed" some of the
> > lines on the cable that are "gnd" on most drives and used them to pass
> > info about drive. Plan is to try replacing it with a GoTek hack to
> > provide fake disk size info.  Some one has done this on a p70. Not
> > sure if this will work here.
> Grr!  I think I'd heard that before, but did not realize the implications until
> now.
> >
> GOTEK-flo
> > ppy-Emulator-Disk-Change
> <monotone>joy</monotone>
> Well, at least it's information that might be a helpful start.
> Do you need the 2.88 MB disk drive?  I thought that OS/2 and the System
> Reference (configuration) disks were 1.44 MB.  I'm wondering if you might be
> able to trade it out with a 1.44 MB drive that might be a little bit happier.

Not sure, but the only drives I have found that work on the odd-ball cable were 2.44. 
I bought one on E-Bay and it also seems to work so I have a spare.

> Also, I think that ThinkPad's used similar (decedent?) floppy technology.
> There might be something you could take from ThinkPads and get it to work
> (with adapter) in the PC Server 500.
> > 2. Messed with the RAID firmware, drive links and drives. Its still
> > Foo Bared. The system came with no CD Drive or 9mm DAT fitted. When I
> > popped that back I think it broke the RAID. For now I have un-plugged
> > the RAID card.
> That means that the existing RAID array is inaccessible.
> > 3. Installed a BT646 Microchannel SCSI card from E-Bay. Its SCSI/2 but
> > not as fast as the RAID card which is wide and of course can do multiple
> i/os.
> I wonder if the RAID card has a RAM cache on it, and if the RAM might be
> failing.  Lord knows what it would take to replace the RAM.  Maybe the cache
> could be disabled?

No the RAID card works when the disks spin up OK. This has always been an issue with that card. I think folks just kept the thing running 24 hours a day.

> > 4. Installed a SCSI2SD instead of hard drive. I have a 32Gb card in it
> > which works out a little less than what was in the server.  Getting
> > the config right for this proved fun. At present I have it set as 2 x
> > 4gb drives. The rest is un-allocated.
> I've not yet had the pleasure of working with a SCSI to SD adapter.
> I'm going to be messing with a Compaq Deskpro XL 560 which uses SCSI.
> I"m hoping to use a SCSI-to-SATA adapter and then use a small SATA SSD.
> *Hoping!*

The SCSI2SD is an expensive card but its very versatile. Up to V5.1 you can split the card into four drives. You can define these as Hard Disk, CD or Floppy.
You can disable/enable SCSI/2 and Parity. You can set the start-up and select delays. Newer cards (v6 onwards) are proprietary but do more disks. 
Useful for getting large amounts of space on old machines that only do 1GB SCSI drives.

> > 5. There is a SCSI CD ROM on the interface as well. This seems to have
> > fits from time to time.
> I thought the SCSI CD-ROM was fairly standard.  Meaning you can probably
> trade it out with a different SCSI CD-ROM or possibly even a DVD-ROM.
> Sure it's not authentic, but it might be happier hardware.  Pick which problem
> you want to fight when.  ;-)

Actually, the IBM SCSI CD rom that came with the system seems the most reliable. It reads CDR media just fine which the one I have for the Microvax(s) doesn't.
It also has sector size select so I assume it will work in the VAX as well. From what I remember OS/2 is picky about SCSI CD drives and has different drivers for some types.

> > 6. I had a couple of goes at installing OS/2 Warp Server 4 (This is
> > Warp
> > 3 with server components). I couldn't get the server to boot from the
> > SCSI2SD but there is a setting hidden in the Server Config that must
> > have got lost.
> If memory serves, you need to specify which card to boot from.  I don't recall
> if the system config specifies what drive on what card or just what card and
> subsequently relying on the card to know what drive (or fixed ID) to boot
> from.
> I wouldn't be completely surprised to learn that there was a partition size /
> location / ID requirement to be able to boot.
> I've long had problems getting OS/2 Warp 4 (CD from IBM) installed when
> booting from disks made from images on the CD.
> I want to say that OS/2 and / or it's boot manager had to have the boot
> manager / partition be less than ~500 MB and within the first 2 GB of the
> drive.
> I don't know that it was 500 MB exactly.  It's likely some multiple of or power
> of 2 or 10 and / or a binary counter width.
> Remember the drives that would have been available for use when the
> machine came out.
> Also, the RAID likely did some translation and might be able to take larger
> drives than the machine could handle directly.

The BT SCSI card will do some of this. It has a BIOS and an option for >4gb drives so the server sees the two drives I have as 0 and 1 and can boot from them
I think it’s a really good SCSI card.

> > 7. At this point I had the SCSI2SD set as 2 x 1GB  drives but decided
> > I needed more space, so I re-set them as 2 x 4gb. The base OS/2
> > installed OK but server portion barfed saying not enough free space. I
> > guess a pointer over flows. So spend an hour copying the CD onto the
> > "C" drive several times. It then installed OK.
> I think I've heard tell of using a small partition for OS/2's boot manager and
> then maybe a 4 GB partition for the OS.
> I believe that OS/2 will use drives / partitions larger than 4 GB, but they may
> be effectively limited to data drives.
> All the reading that I've done on the P/390 installations have always had the
> P/390 stuff on separate drives, typically D:.

Yes I actually have saved a bit of space on the first hard drive for other things...

> > So at this point I had an OS/2 system that booted. I couldn't get the
> > P390 software to install as it wanted Communications Manager and I
> > didn't have it.
> Oops!
> > For those who don't know the base OS/2 has virtually no networking
> > included. IBM chose to separate networking as a separate product,
> > Communications Manager and charge a small fortune for it.
> I don't know if that was specifically chosen on purpose or a side effect of how
> things were distributed at the time.
> Remember that Most OSs didn't have native networking ability.  Windows 3.x
> got it as somewhat of a back port very late.  Windows 95 had minimal
> networking when it first came out.  I think most of Windows networking was
> introduced in NT and shifted to 3.x / 95.
> Also, I believe that Communications Manager was a product that could be
> added to an earlier version of OS/2 (same major version) that added
> networking.
> Even when I install Warp 4 in VM, I see that the Base OS gets installed and
> then the Communications Manager (read: server) components get added
> later.
> I believe this also patterns after what mainframe OSs and other unixes did at
> the time too.
> Ultimately I don't think this was malicious / extortionist behavior.
> Rather differences at the time.

I think whilst much of the above was true, it was mainly about making money. CM cost nearly twice what you paid for the base OS/2. IBM produced several "crippled" versions of Networking in OS/2 that would only do TCP/IP via a modem. If you read around there are several hacks to get this talking to the networking stack in Warp/Connect to talk TCP/IP over the LAN. I think some of this was a mis-reading of the Market by IBM at the time, they didn't realise how the PC market was changing so PCs were a commodity. When Windows/95 came out with smooth support for Windows/3 apps but with 32-bit apps as well, TCP/IP server and client included, and a much quicker and simpler install for users, OS/2 had to be dead in the water. Many will say "OS/2 was technically superior" but if you can't afford it, you use what you can afford. It wasn't only IBM that miss read the market. Having spent a week installing DEC Pathworks for Windows client licences on a room full of PCs so they could connect to a copy of Netware running under VMS on Alpha, when no such mucking about was needed for Netware on PC hardware I can see why they failed. Yes the alpha had a faster CPU but the disks were the same and the Mylex Raid controllers in Alphas were as bad as the Cheeta in the PC Server 500 (I think they share some code). Any way rant over....

> > I think at this point I also installed service from a WarpUp! CD. I
> > have also installed Netscape 4.6 and InfoZip from this CD but not Java.
> Nice.
> > However, I have since found that Personal Communications which
> > includes
> > 3270 and 5250 terminal emulators also includes a "mini" version of
> > Communications manager and should be sufficient to run the P390 code.
> Eh....  I don't think that /I/ would bet on that.  Maybe that is the case.

I checked with others off list. They tell me theirs works with just PCOMMS 4.2.

> I've run into multiple different versions of / products from IBM that have
> communications in the name.  I think that Communications Manager was the
> networking add on for (and rolled into later versions of) OS/2.
> The Personal Communications that I've run into was more a client application
> including a terminal emulator.

PCOMMS is "just" a client emulator, but as OS/2 has no comms stack when you install it on OS/2 if its to work with no pre-reqs, it has to include a complete comms stack. 
It will talk to a mainframe over TCP/IP but it will also talk directly to SNA over LAN and WAN and also via dedicated 3270 hardware. It will do SNA over SDLC.
On windows it installs several services so you can trace token ring traffic. Perhaps more than just a client emulator, but these days that’s how its used.

> > I have now installed that but at first I still couldn't get the P/390
> > support code to install. However, I found I wasn't installing the very
> > latest version of the P390 support code. That has now gone on, after
> > copying one disk in another PC as the drive in the server decided it
> > couldn't read it. I can now load the microcode into the card, but I
> > can't connect the 3270 emulator as a console.
> *nod*
> See previous comment about 1.44 MB vs 2.88 MB disks and what you truly
> need.
> > I have now re-read the documents and think I know what I need to do, I
> > don't have the IP port in the P390 config matching the port in PCOMMS.
> Hum.  I wonder how networking on the P/390 and it's emulated 3174 (?)
> Establishment controller work.
> If it's anything like Hercules, you'll need one IP for the P/390 and a different
> IP from OS/2.  —  I could easily be completely wrong.

Not sure myself. I haven't configured that yet. I figure I don't need it yet as like Hercules the 3174 device emulator will do TN3270 to local non-SNA 3270.

> > I also think I may need to tweak the OS/2 config.sys.
> Quite likely.  I think the vast majority of OS/2's config lives in the config.sys
> file (or other similar files) and requires a reboot to apply the new settings.
> > At some point I have also zipped up a mainframe OS from Hercules,
> > copied it to a CD and un-zipped it onto the server. Hopefully tomorrow
> > I should be able to load VM/CMS.
> I'll be interested to see how that turns out.
> > I also am still having issues with the Video Card. Its IBM SVGA
> > Adaptor/1 which I believe should do 1024 x 768 but its stuck in 800 x 600.
> Hum.
> I've found video drivers under OS/2 to be questionable.  I've been stuck in
> VM, which has it's own problems.
> > I can't get PMVNC to run. It says its started but when I try the
> > config program it says it can't find the started program.
> :-(
> Thank you for sharing, it was a very interesting read.

No problems Grant. Its 11.00 AM in the UK so time to wake the XYL (X Young Lady, a term used by hams to refer to their wifes in Morse Code. One which has not made to text speak). 
It’s a sunny day so probably won't get to play until tea time... 

> --
> Grant. . . .
> unix || die


More information about the cctech mailing list