Micropolis 1525 stuck heads

Chris Zach cz at alembic.crystel.com
Mon Sep 20 01:13:58 CDT 2021

That is what fixed it, hair dryer blowing around the unit. I stayed away 
from the circuit boards and just kept moving to different places. I 
thought a head was sticking, but it finally started to move a bit so it 
might have been a really gummed bearing. Or #3 head was stuck and 
loosened, most of the errors are on that head.

Running it through the MFM tool got all but 200 or so sectors on the 
first pass, most errors were on head 3 but tapered off after cyl 500. 
Seems like a normal copy of Accent, no special information so it might 
not be worth taking the world apart to get it working.

Thanks everyone. Back to

On 9/20/2021 12:17 AM, Jonathan Stone via cctalk wrote:
>   I had suggested a hair-dryer, as recommended circa 20 years ago for drive "stiction" after disuse. It seems that worked.
>       On Sunday, September 19, 2021, 08:58:57 PM PDT, Bill Degnan via cctalk <cctalk at classiccmp.org> wrote:
>   I have simply opened and physically moved the disk counter clockwise a
> turn, in a clean dust-free place.  Or try putting in an oven on warm for 3
> minutes a side, all four sides to loosen the grease.  Might sound crazy but
> these have worked for me before
> Bill
> On Sun, Sep 19, 2021, 10:18 PM Zane Healy via cctalk <cctalk at classiccmp.org>
> wrote:
>> 20+ years ago, I remember people talking about disassembling these to fix
>> the issue.  I’ve never tried.  Though I have one or two that might benefit
>> from is.  If the CLASSICCMP archives from ’97-2000 are online, I’d
>> recommend running a search against them.
>> Zane
>>> On Sep 19, 2021, at 3:58 PM, Chris Zach via cctalk <
>> cctalk at classiccmp.org> wrote:
>>> Ok, so out of the basement came a Micrapolis 1325 (the old Dec RD53
>> disk) with what appears to be stuck heads. Rotor tries to move under power
>> but can only take out slack. Will move backwards a bit.
>>> Is this stuck head, and what would be the best way to free it? The
>> reason I'm asking is this disk had a SA1000 adapter mounted under it so I
>> am pretty sure it was a PERQ disk. Which means data may be priceless. And
>> of course it's stuck.
>>> Thoughts?
>>> CZ

More information about the cctalk mailing list