Ultrix-11 Networking

Douglas Taylor dj.taylor4 at comcast.net
Sat Aug 28 15:13:36 CDT 2021

On 8/28/2021 1:15 PM, Bill Gunshannon via cctalk wrote:
> On 8/28/21 1:03 PM, Douglas Taylor via cctalk wrote:
>> Yes, I did create a new kernel and copy it to the correct place and 
>> chmod 644 the new unix file.
> Did yo have fun playing with the overlays?  :-)

I don't know what this means.  The kernel creation was automatic, it 
seemed to check for enough room.

>> On my Debian system I can install ftpd and telnetd (they are still in 
>> the Debian package list) which are the unsecure ones, but I don't 
>> know how to configure them or start them.  As in, # systemctl  
>> restart ftpd
> Probably easier to turn them on on Ultrix-11.  Just modify inetd.conf.
> Actually, I just looked and ftp is on by default. Telnet is not.
I edited inetd.conf to uncomment telnet.  It helped.
>> It turns out to not be a hot topic: "How do I make my Liinux system 
>> less secure?",  but for us that noodle around with old computers with 
>> obsolete operating systems it is exactly what we need.  In the past I 
>> remember using Filezilla to go from a Windows7 machine into a Vax 
>> without any problem.
> I suspect you will be somewhat disappointed with networking in
> Ultrix-11.  Not that there is something wrong with it, just that
> the hardware is nothing like you are used to.  In the early days
> of networking it was not unusual for systems like the PDP-11 to
> crash just because of the traffic passing by on their network
> connection.  The advent of switches helped alleviate that but it
> is still common to crash a system by pushing data at it from a
> modern ftp.  I expect FileZila will do it.  To be honest, I always
> preferred Kermit for moving files.  It is possible to keep packet
> sizes down and even slow down the transfer rate to give the PDP
> time to handle it.
> bill
I brought up a Vax Alpha 3000-300 and tried interacting with the 
Ultrix-11 simulation:

Starting in Ultrix-11 I could log into the vax via telnet. Ultrix-11 ftp 
was able to transfer a short ascii file from the Vax to the Ultrix-11 sim.

Going the other way, Ultrix-11 would reject an ftp request from the vax, 
here is the error message -

$ ftp
%TCPIP-E-FTP_NETERR, I/O error on network device
-SYSTEM-F-UNREACHABLE, remote node is not currently reachable

Ultrix-11 would allow a telnet connection (after the change to 
inetd.conf) and I could do an ls, but when I asked for a man page it 
hung up.  Nothing after that, had to kill it.

I got the same result whether I was telneting in from the Vax or Linux 
computer.  Probably not news to you.  I wonder if real hardware works 
just like this....

It was good to find out that you can get things in/out of the Ultrix-11 


More information about the cctalk mailing list