Unisys MCP (was: Re: UniSys ClearPath OS/2200 Express?)

Alan Perry aperry at snowmoose.com
Thu Jul 2 15:41:53 CDT 2020

On 7/2/20 1:05 PM, Kevin Monceaux via cctalk wrote:
> Alan,
> On Wed, Jul 01, 2020 at 08:00:00PM -0700, Alan Perry via cctalk wrote:
>> Got it installed and running on a Windows 10 VM on my MacBook. Pretty
>> interesting, but I haven't used MCP since '89 and seldom used the ODT
>> (console) on A Series systems when I did, so lots of trying to recall
>> how to do stuff.
> I got it installed and running on a Windows 7 VM on my 2009 Mac last night.
> I've never used MCP before, so there's been lots of reading trying to learn
> how to do stuff.  I didn't have much time to work with it last night, so I
> haven't gotten very far yet.
> Has anyone attempted to run MCP Express under Wine on Linux?  I don't know
> how long I'll be able to use the VM I currently have it running on.  I don't
> have a Windows license key for it.

I have never had Windows stop working despite not activating it and have 
gone at least 6 months without doing so. Despite now working for MS, I 
don't know the ins and outs of Windows activation. (I work on embedded 
Linux there.)

I have been using those blogs to remind myself of how it all work. I 
worked on products where PCs (ET2000 PC compatibles and B2x BTOS 
systems) interacted with mainframes. Now the joys of block mode 
terminals are coming back to me.

I did my day-to-day work with CANDE (Command AND Editor) and with MCP 
Express one get to that through MARC. However, when I run the MARC 
script, the Windows VM crashes.


More information about the cctalk mailing list