RS/6000 7043-140 boot floppies

Alan Perry aperry at
Tue Feb 19 10:50:15 CST 2019


It has been reported that Solaris 2.5.1 does work with the 604e, which the 7043-140 has, so I will be looking for another box to run 2.5.1 PPC on.

I worked for Sun on Solaris back when the PPC port was done (and work for Oracle now on Solaris). I asked among Solaris folks (current and former) about PPC compilers and “possibly gcc 2.95 otherwise cross compiling” was suggested.


> On Feb 19, 2019, at 3:09 AM, Rico Pajarola <rp at> wrote:
>> On Mon, Feb 18, 2019 at 6:49 PM Alan Perry via cctech <cctech at> wrote:
>> Is there some trick to making boot floppies for the RS/6000 7043-140 (a 
>> mid-90s PReP architecture machine)?
>> I initially tried to install Solaris 2.5.1 on it and created the boot 
> #wrong43p
> Solaris 2.5.1 PPC doesn't work on that machine.
> I can't find the HCL doc, but according to the files present on the CD it runs on:
> IBM 6040 (ThinkPad 820)
> IBM 6042 (ThinkPad 850)
> IBM 6015 (PowerSeries 440, 7020-40P)
> IBM 6050 (PowerSeries 830, 7248-43P)
> IBM 6070 (PowerSeries 850, 7248-43P)
> IBM 7248 (43P-100, 43P-120, 43P-132)
> Motorola PowerStack Series DT/E/MT
> The 7248-43P is substantially different from a 7043-140 "43P". I have it running on a PowerStack Series E.
> Did anyone ever unearth the Sun compiler for that?
>> floppy by dd'ing the image using a SPARCstation (running NetBSD). I 
>> dd'ed the image over, dd'ed it back and verified the SPARCstation could 
>> read back what it had written to the floppy. The RS/6000 loads what is 
>> on the floppy, but hangs transferring control to what it loaded.
>> The 7043-140 does not appear on the list of supported systems in the 
>> Solaris 2.5.1 release notes, so, even though 2.5.1 supports PReP and the 
>> 7043-140 is a PReP machine, maybe they aren't compatible, so I tried 
>> NetBSD. The 7043-140 is listed as a supported system.
>> The NetBSD boot floppy images are confusing to me. The files are too 
>> large to fit on a 1.44M floppy. I didn't see instructions on how to make 
>> boot floppies out of the .fs files one can download in the install 
>> instructions. I went ahead and tried to dd the part that fits onto a 
>> 1.44M floppy and try to boot that and of course that failed. I have 
>> e-mailed the NetBSD prep mailing list and no response from that.
>> The system does boot the AIX install on one of its hard disks, but this 
>> is a recycled system and I don't have usernames/passwords for that install.
>> Does anyone here have a suggestion on how to proceed?
>> alan

More information about the cctalk mailing list