PDP-11/45 RSTS/E boot problem

Wayne S wayne.sudol at hotmail.com
Mon Feb 4 14:17:03 CST 2019

Noel,  it might be a wonky filesystem.

I’ve had ls -l seg fault because of bad attribute data on a file in a directory on Solaris.

Interestingly, ls (without the -l) worked okay.

Maybe fsck or the equivalent command may show something.

It was a Solaris system with many concurrent users so I couldn’t  take it down to  run fsck so I

ended up writing a quick Perl program to just list file names and then modified it to get the attributes. It seg faulted when it came to the bad file name.  I used Perl unlink to kill it and everything was okay.

The corruption probably came because the entire disk was going bad.

Just a thought.

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10

From: cctalk <cctalk-bounces at classiccmp.org> on behalf of Noel Chiappa via cctalk <cctalk at classiccmp.org>
Sent: Monday, February 4, 2019 11:24:19 AM
To: cctalk at classiccmp.org
Cc: jnc at mercury.lcs.mit.edu
Subject: Re: PDP-11/45 RSTS/E boot problem

    > From: Jay Jaeger

    > This sort of situation, where DEC diagnostics run OK but UNIX has issues
    > was reported to be not all that uncommon - to the point where the urban
    > legend was that some DEC FE's would fire up Unix V6 as a sort of system
    > exerciser.

Amusing! Never heard that; our -11's were never under maintenance, so DEC FE's
never worked on them.

    > Make a copy of ls, and see if the copy also fails

It acts just like the original; fails when run by itself, runs OK when 'sleep'
is also running (in the background).

    > From: Bob Smith

    > We finally had the cpu backplane replaced

Ow. Not an option for Fritz, I expect. (I dunno - anyone have a spare /45

    > From: Paul Koning

    > Is there any way to attach a logic analyzer to various data paths on
    > this machine?

I had suggested to Fritz that the symptoms led me to believe that it was time
to deploy a LA, especially since the MM trap only occurs once between him
typing 'ls' and the process failing - i.e. easy to trigger on.

He offered me the options of look at the IR or at the UNIBUS - I opted for
the IR so we can see _exactly_ what the machine _thinks_ it is doing! No
report back yet, though.


More information about the cctalk mailing list