DEC 3000 (alpha) faultfinding

Peter Coghlan cctalk at
Wed Apr 4 06:14:07 CDT 2018

> > I ran the various tests provided by the different jumper settings on my second
> > 3000 600 and I found that the memTest (no-cache) LongWord Memory Test (position
> > 5, J3) failed as well as the tests involving the cache.  In an attempt to find
> > which memory was failing, I swapped around the memory risers.  Bizarrely, the
> > (no-cache) failures went away completely when I swapped around the front two
> > risers.  The failures returned when I swapped them back.  This is very odd as
> > the two risers appear to be identical and seem to be populated with identical
> > SIMMs.
>  Have you tried cleaning the pins?
>  The riser connectors are the same style DECstation 5000/200 MS02 memory 
> modules use and I had cases of ECC errors appearing with those which went 
> away once thorougly cleaned with IPA.  Lone reseating didn't help.

I did some more experimentation and I found that the failures consistently
occurred when a particular riser was installed in one of the rear facing
riser slots and consistently did not arise when that riser was installed in
one of the front facing slots.  I also noticed that the mini console
consistently reported:

memSize 000000c0.000000c0

when the the failures occurred and consistently reported:

memSize 000000a0.000000a0

when they did not occur.  The failures could not be provoked when I swapped
the suspect riser with one from the other machine.  Further swapping of
individual simms on the suspect riser narrowed down the cause of the problem
to one particular simm on that riser.  Unfortunately, after eliminating the
faulty simm, the cache faults and occasional machine checks were still present.

Going back to the other 3000 600 that does not experience machine checks and
putting back it's full set of good memory risers, I am left with just the
cache issues to deal with.  Unlike the Alphaserver 1000A, there does not
appear to be any obvious way of disabling the cache.  It appears it could be
done if I could write to the ABOX_CTL and BIU_CTL registers.  Unfortunately,
while this could probably be done with the "dc" mini console command on some
other processor models, this command does not seem to be implemented on the

Peter Coghlan

>   Maciej

More information about the cctalk mailing list