Liam Proven lproven at gmail.com
Mon Nov 20 08:35:07 CST 2017

On 17 November 2017 at 19:02, Tomasz Rola <rtomek at ceti.pl> wrote:
> Please excuse me if my remark is unnecessary, but if I read you right,
> you have:
> 1. Downloaded "empty" disk image - which apparently boots enough to
> display two dots


The original DR-DOS Enhancement Project website --
http://www.drdosprojects.de/ -- is no longer there.

The download I found for 7.01-8 was here:


This download includes what it claims is a bootable diskette. It is
not a bootable diskette. It is an empty diskette image.

What I've done is make it bootable.

> 2. Copied system (DOS) files on it (say, from backup)

No, from within the same download archive.

> 3. You have not erased the boot-sector-from-the-i-net? So it is there
> and still boots the (now fully functional) DOS?


> If so, perhaps you should start over from totally new, empty image?

I can do, but I need some more tools in my VM first. Unfortunately my
Mac with the more complete disk image is currently out of action.

> Not copy from your currently working image, but from your backup. Just
> in case.

I can try it.

> Or at least try to disassemble the boot sector to see what it
> is doing (I have no idea how, but somehow it must be possible).

> "Things" can escape from VMs. I have plenty of Xen warnings and bug
> descriptions in my old mailboxes, chances are there will be more.

It's possible. I'm not working on Windows systems, so I don't have
virus scanners in place.

>> All I need to do now is work out how to make the hard disk bootable,
>> and I'm in business.
> Boot some other OS, (I am partial to GRML Linux, well packed with
> rescue stuff and more - https://grml.org/ ); + fdisk, mark bootable?

Er, yes. Thanks. I _do_ know about managing DOS hard disks, thanks. :-)

The problem is that the DR-DOS 7.01 tools cannot use the 7.01-8 files
to make a bootable volume in the normal ways (wither ``FORMAT /S'' or
format then ''SYS [drive letter]:''.

So I need to try other things, which are not on the current system.

>> The DR-DOS 7 SYS command won't do it, as the files aren't named
>> I copied them to the expected names. SYS completes but the disk won't boot.
> Perhaps you should try again, copying one file each time, in the right
> sequence (I do not recall, which one, but only two files, similarly to
> how sys would do it). I did such "manual sys" once on MSDOS 6 (5???)
> floppy and it worked (booted).

It can sometimes work but it's not guaranteed.

I have tried all the obvious methods. Now I am going to need 3rd party tools.

The same problems are preventing me from making a PC DOS 7.1 hard disk
image bootable: the older DOS commands won't use the newer "kernel"

> Watcom C?

Er, no. I am not compiling anything here. I am merely trying to make
some already-available parts into a working system.

> I keep promising myself to do such stuff one day, only with FreeDOS,
> plus some utils to refresh my long forgotten i386 assembler. So, it is
> probably FASM nowadays. And some editor which is at least minimally
> usable... Or some really cheap alternative, with the same under

FreeDOS is fine if you like it. For me, it is just a little too unlike
the "real thing" for comfort. And as I'm interested in playing with
some fairly extreme DOS stuff -- multitaskers (DESQview, etc.) and so
on -- I want the highest level of compatibility I can achieve.

Liam Proven • Profile: https://about.me/liamproven
Email: lproven at cix.co.uk • Google Mail/Talk/Plus: lproven at gmail.com
Twitter/Facebook/Flickr: lproven • Skype/LinkedIn/AIM/Yahoo: liamproven
UK: +44 7939-087884 • ČR/WhatsApp/Telegram/Signal: +420 702 829 053

More information about the cctalk mailing list