RL02 Spinup fails

Aaron Jackson aaron at aaronsplace.co.uk
Mon Nov 6 12:21:53 CST 2017

This can probably be ignored. I since realised it's almost definitely an
issue with my terminator. Although, it doesn't matter how many times I
build a terminator, it won't work. I based my terminator off Mark
Blair's RL02 to USB project:



Aaron Jackson via cctalk writes:

> Hi everyone,
> I have managed to hook up an RL02 drive to my PDP-11 (thanks to Dave
> Wade for the drives) . This took me longer than I thought it would - I
> tried with a flat ribbon cable with a DIY terminator going straight into
> board , but couldn't get it to work. Removed the terminator, and the
> fault light turned off. So that's positive.
> I tried to load a cartridge, which I had cleaned, inspected and
> generally appears to be in good condition. It started to spin up and I
> could hear it getting faster, but after 30-40 seconds the fault light
> returns. I made a short video demonstrating this:
>          https://www.youtube.com/watch?v=japwBBodO8U
> According to the manual the fault light can appear for the following
> reasons:
> - Drive select error... Surely this would come on at the start?
> - Seek time out error... I'd have to hear the heads move first
> - Write current in heads during sector time error... Same as above
> - Loss of system clock... The fault light would be on from the start.
> - Write protect error... I don't think it got that far
> - Write data error... Same as above
> - Spin error... Is this the only remaining fault?
> So could the only cause be a spin error? I am wondering if the belt is
> slipping or something like that?
> Can anyone offer some advice?
> Thanks,
> Aaron.

Aaron Jackson
PhD Student, Computer Vision Laboratory, Uni of Nottingham

More information about the cctalk mailing list