RL02 Spinup fails

Tony Duell ard.p850ug1 at gmail.com
Mon Nov 6 12:19:45 CST 2017

On Sun, Nov 5, 2017 at 5:43 PM, Aaron Jackson via cctalk
<cctalk at classiccmp.org> wrote:
> Hi everyone,
> I have managed to hook up an RL02 drive to my PDP-11 (thanks to Dave
> Wade for the drives) . This took me longer than I thought it would - I
> tried with a flat ribbon cable with a DIY terminator going straight into
> board , but couldn't get it to work. Removed the terminator, and the
> fault light turned off. So that's positive.
> I tried to load a cartridge, which I had cleaned, inspected and
> generally appears to be in good condition. It started to spin up and I
> could hear it getting faster, but after 30-40 seconds the fault light
> returns. I made a short video demonstrating this:
>          https://www.youtube.com/watch?v=japwBBodO8U
> According to the manual the fault light can appear for the following
> reasons:
> - Drive select error... Surely this would come on at the start?
> - Seek time out error... I'd have to hear the heads move first
> - Write current in heads during sector time error... Same as above
> - Loss of system clock... The fault light would be on from the start.
> - Write protect error... I don't think it got that far
> - Write data error... Same as above
> - Spin error... Is this the only remaining fault?
> So could the only cause be a spin error? I am wondering if the belt is
> slipping or something like that?
> Can anyone offer some advice?

It's been some time since I worked on one of these and I don't have
the printset to hand, but from what I remember the fault indicator
circuit is triggered by a (logically) many-input OR gate. Probably
a NAND in practice, which is why I said 'logically'. The inputs to
said gate come from the circuits that detect various faults.

What I do is to look at each of those inputs in turn and see what
is triggering the fault indicator. Then work back from there.


More information about the cctalk mailing list