Looking for tips debugging DEC TC01 controller

Josh Dersch derschjo at gmail.com
Tue Nov 30 16:14:34 CST 2021

On Tue, Nov 30, 2021 at 1:57 PM Fritz Mueller via cctalk <
cctalk at classiccmp.org> wrote:

> > On Nov 23, 2021, at 3:17 PM, Josh Dersch via cctalk <
> cctalk at classiccmp.org> wrote:
> > I picked up a TC01 in trade (for a TC08) a couple of weeks back and this
> > past weekend I got it hooked up and powered up with my PDP-8/I + TU55
> > transport.  I've been debugging it and have solved a couple of issues but
> > the current one has me stumped and I'm looking for advice, hoping I
> > overlooked something obvious...
> Any updates here, Josh?  I’m not familiar enough with 8’s or their
> peripherals to offer any relevant suggestions, but I’m curious to hear what
> you find and how you crack it!

After poking at it awhile, a friend of mine pointed out that the W1 flip
flop is set up so it will only toggle once, after the first "1" bit comes
in from W2.  This is actually pointed out in the TC01 maintenance manual
but I had managed to overlook it.  I'm still not entirely sure why it
behaves this way (I guess so it only gates mark blocks after the first real
data goes through the WINDOW register?) but it's good to know it's working

Tracing further through the circuitry reveals that the first SEARCH
operation executed by the "Search Find All Blocks" diagnostic isn't
executing properly -- it sets the GO bit momentarily and all the command
bits seem to be making it to the controller, but before the drive begins
forward movement "GO" goes low and after that nothing happens; the
diagnostic halts after waiting for an interrupt for about 30 seconds.
Regular MOVE operations appear to work fine.  I've got a ton of signals to
dig through so I'm not sure what's going on yet.  Think I may need to get
the Logic Analyzer out for this one.

- Josh

>     —FritzM.

More information about the cctech mailing list