Jay Jaeger cube1 at
Sat Aug 28 14:12:22 CDT 2021

On 8/27/2021 10:08 PM, Jay Jaeger via cctalk wrote:
> On 8/26/2021 2:51 PM, Jay Jaeger via cctech wrote:
>> On 8/25/2021 5:58 PM, Mike Loewen via cctalk wrote:
>>> On Wed, 25 Aug 2021, Dennis Boone via cctalk wrote:
>>>     As a few of the signals on the 34-pin connector are different 
>>> than the Shugart layout, I'm considering making up a custom cable and 
>>> connecting it to my Catweasel MK4+. I have a utility from Andrew 
>>> Lynch called "cwns", which is a modified version of "cw2dmk" to read 
>>> Northstar hard-sector (10 SPT) diskettes. I might be able to modify 
>>> that to read the VG 16 SPT diskettes, if the 1043-2 will work with 
>>> the Catweasel.
>> It will not - but it has nothing to do with the cabling.  I already 
>> tried with my catweasel.  I was able to read flux, but between the 
>> hard sectoring and (possibly) different meta markers for the floppy 
>> sectors, the .scp file is useless.  I just got my Cypress board for a 
>> fluxengine in the mail yesterday, but haven't set it up yet - maybe 
>> tomorrow.  The website for fluxengine indicates it ought to work.
> The fluxengine almost works with my Micropolis drives - but there are 
> some problems.
> 1)  The drive select pins are different.  I am having *some* luck access 
> one driver of my daisy-chained pair, but not the other.  The fluxengine 
> setup and/or the drive also seem to get confused when I try to access 
> the other drive.  I submitted an issue on github for more flexible drive 
> selection / motor control capability.  One could work around this with 
> suitable cabing / jumpering.
> 2)  So far I have not been able to read an entire Mod II disk 
> successfully - lots of good sectors on two, but not all without errors 
> on either one.  But I have not tried cleaning the heads on my drives, or 
> trying the Mod I with different select jumpering.
> 3) The Micropolis drives are slow stepping, so I added multiple commands 
> to seek to cylinder 0 to my script - not sure if that is actually 
> working right.

Another update.  Without messing with the cable pinouts the fluxengine 
will only support a Micropolis drive strapped for DS2 (as fluxengine 
drive 0).

I have successfully read a couple of Mod I disks (143KB).  But some have 
not read very well.  Sometimes it goes "off the rails" and says there 
are 77 tracks, even when the input config specifies 35.  My guess is 
that at the least the decoder could probably need some improvement - a 
task I am not up for, at present.

>>> Mike Loewen                mloewen at
>>> Old Technology      
>> JRJ


More information about the cctech mailing list