Intel 8272 based floppy controller & Missing Address Mark

David Kuder dk at
Thu Nov 28 09:06:14 CST 2019

I've tried using the 8" drives as 8" drives with the clock input to the
8272 set correctly, and likewise with the 720KB 3.5" emulator (and even
360KB 5.25" emulation).  On physical and virtual disks I'm getting the same
error trying to read or write data. Formatting steps through all the tracks
without error, and I can see a write status indicator on the GoTek

Across all of the formats I've tried, they use MFM and not FM, and I can
see the MFM bit set in the command byte.  I can try building FDU and the
BIOS to support FM encoded disks, and see if that works.  I'd love to see
some kind of progress, even if it is single density.

Thanks for the help,

On Thu, Nov 28, 2019, 1:08 AM Fred Cisin via cctalk <cctalk at>

> I'll agree with Chuck, that FM/MFM seems a likely possibility.
> index blindness can prevent seeing the first sector, but it should see
> other sectors.
> What is on the disk that you are trying to read?
> You are using an 8" drive, but you mention settings for 720K.
> 720K (MFM) is normally 250K bts per second (300 K at 360 RPM in a 1.2M)
> 8" (MFM) is normally 500K bits per second.
> 8" FM is 250K bits per second.
> Is the data transfer rate consistent with what you are trying to read?
> Do you have a scratch disk that you can spare?
> Set up the code to FORMAT a track (eventually appropriate loops to format
> the whole disk).
> After formatting a track, and without doing any stepping to another track,
> try to read it.  FM/MFM and data transfer rates and even sector
> header (CHRN) should therefore be compatible.
> If you have another machine, try reading THAT track on the other machine
> and check what it sees.

More information about the cctech mailing list