Who changed the gravitational constant (Dec pdp11 stuff)

Chris Zach cz at alembic.crystel.com
Sat Nov 23 08:14:29 CST 2019

> I seem to recall that when the ribbon cable is in backwards, the fault 
> light comes on.

True. First cable faults hard (READY/FAULT on) no matter what. Second 
cable would turn off the Fault light and allow spinup (right direction) 
and ready. However when I tried to boot the drive went fault.

Dug out a third (softer, less rigid) cable, same effect. Then I 
remembered I bought the controller working on Ebay some 25 years ago, so 
I went through my pile to find the original controller. Plugged that in...

Drive booted to RSX11M+ 4.2. Great, I have a blown board and a good 
older controller. Enough to get going....

During all of this I had a minor setback: The MSV11-QC board (the one 
with 4mb of memory on it stock) failed startup diagnostics with what 
looks like a stuck bit. Used an 11/23+ to verify this and find the 
memory region, now I need engineering schematics for that board so I can 
replace one of the 41256 memory chips. On the positive side it looks 
like a pretty obvious stuck bit, just need to know which chip is at that 
address and memory location....

Fortunately I had a Clearmation (I think) backup memory board that has 
only 2Mb of memory. Enough to get going at least...

Never dull. At least I can boot RL02's (will check more cables and such 
today) which means I can get RSX11M up and figure out what went wrong 
with my Hitachi ESDI disk (it's on an MTI controller which is *super 
fast). That's the gold standard, I think it's a 300mb disk in two 
partitions. One has RT11 on it (boots, limited drivers), the other has 
RSX11M 4.0 with all my code, games, programming languages, and so forth. 
When I try to boot that it faults to ODT, which could be a disk read 
failure or possibly something wrong with the monitor. RSX11M 4.0 was 
exceptionally finnicky when it came to devices and maybe something is 
missing and causing it to blow up....


> Paul
> On Fri, Nov 22, 2019 at 7:55 PM Chris Zach via cctalk 
> <cctalk at classiccmp.org <mailto:cctalk at classiccmp.org>> wrote:
>     Normally my answer would be "no". *However* there is mention that
>     changing 3 jumpers on an RL02 will allow you to read an RL01 pack (not
>     write).
>     http://www.pdp-11.nl/peripherals/disk/rl-info.html
>     So... Maybe. However right now I'm trying to get the disks up. It's
>     been
>     20 years, and my cables are not in the best of shape. One cable seems
>     totally dead, as the RL02 flunks when connected to the controller
>     (DRIVE
>     0 and FAULT always on). With the second cable all lights are off and
>     the
>     drive spins up and goes ready, however as soon as I try to boot the
>     drive goes to FAULT. If I remove the 0 drive selector and put in a 1,
>     the fault goes out, however trying to boot DL1: gives the same error.
>     This happens on both drives with two different boot packs (old RSXM38
>     images). So it is either the cable (possible as two pins were bent and
>     needed to be straightened) or the controller (also a maybe, been 20
>     years I might have another spare somewhere around here). I'll order
>     some
>     DeOXit, ohm out the first cable to see if it's bad, and try again next
>     weekend.
>     Never dull. On the positive side I saved at least one set of RL02
>     rails.
>     So there is that.
>     C
>     On 11/22/2019 2:36 PM, Al Kossow via cctalk wrote:
>      >
>      >
>      > On 11/22/19 11:16 AM, Chris Zach via cctalk wrote:
>      >> That
>      >> could be a problem if I want to re-load Cobol 81 onto this
>     RSTS/E system.
>      >
>      > weren't RL01s usable in an RL02?
>      >
>      >

More information about the cctech mailing list