Floppy drive (DSDD) DOS compatability woes (are these drives ok?)

rescue rescue at hawkmountain.net
Tue Nov 5 21:29:03 CST 2019

On 2019-11-05 13:45, rescue wrote:
> Been away for some time from the mailing lists....  getting back into
> my classic gear again....
> I have two of these Qumetrack 542 drives.
> While testing my 360K drive collection (8 drives.... I must be
> slacking :-) ...), 2 worked, 4 had issue (resolved with a good head
> cleaning), and 2 (both of the Qumetrack 542 drives (I have two of
> them)) have mixed results.  My testing is on a Tandy 2500SX/33 using
> the Tandy straight through cable and with the drives set do DS0.
> I seem to have no issue with Dunfield's testfdc (using testfdc/x a:)
> with these drives, doing SS and DD and getting 'pass' from testfdc.  
> I
> can also use his imagedisk program, go to the alignment section, and 
> I
> can track the drive properly up an down the disk.... it is just DOS
> that can't seem to do it.
> However, when I do a format a:, the drive will format through the 40
> tracks, then instead of the heads returning to track 0 quickly, they
> do these small stepping 'bursts' and DOS times out saying 
> failure.....
> it probably would have worked if DOS would wait 10 seconds or more 
> for
> the drive to move to track 0.
> I've never seen behavior like this.  I even tried an external power
> supply in case the Tandy one wasn't up to driving the full height
> floppy drive due to an aging marginal supply, but that didn't help
> anything.
> I've now also had one of them shut down the power supply (a shorted
> tantalum cap I'm sure).
> I've looked through the manual on the drive, I've tried the HM, HS,
> and no jumper setting for stepper motor power, same results in all
> cases.
> I'm trying too determine if these drives are good.  I'm planning on
> using them in a Tandy Model III that is upgraded internally to a 
> Model
> IV, but I feel these are basic drives and should work in DOS fine 
> too.
> I hope someone has a clue, as I'm tapped out of them currently.

Well, For reference... I figured it out.

Apparently the newer system (Tandy 2500SX/33 (386SX cpu)) has to fast 
of a step time.

I found a program called flopparm.com and teststep.com which are part 

By using:

flopparm custom=10,15,15,8

I was then able to format a disk using DOS format.

I won't be using the drive on this system, and it will be being used 
likely in a TRS-80 Model III, so I'd imagine the older system won't be 
as aggressive on the timings as the 386SX is and it won't be an issue.  
So, both of my drives are confirmed good (well, after I replaced the 
shorted tantalum on one of them).

-- Curt

> Thanks,
> -- Curt

More information about the cctech mailing list