Sun dead battery / unresponsive openboot

Jerry Kemp other at
Wed May 6 23:38:00 CDT 2015

I haven't had a chance to catch up on email for a few days, so I am hoping this 
is old stuff and you have your box up and running.

I have two comments for you.

1. in addition to Ryan's break comment, you may also want to try a STOP-N , 
which should reset the OBP back to defaults.

2. Back in the early 2000's, I was at a small company, and one day my boss 
brought me a stack of Ultra-1's and Ultra-2, which we used small servers, 
serving up DNS, FTP, etc.

Several had dead OBP batteries, but I was still able to boot them, although I 
still received the error.   I was too lazy to do anything (physical) about that, 
but what I did, was to run a script, early in the boot process, to assign a mac 
address to the ethernet card, before any daemons came up, and those boxes served 
us well for many years.    The script was a really simple one liner of something 

ifconfig hme0 ethers 08:00:20:c0:ff:ee

or something similar.

Again, hope you have this all figured out and running.


On 05/ 3/15 05:51 PM, Ryan K. Brooks wrote:
> Have you tried sending a break?
>> On May 3, 2015, at 5:50 PM, Jules Richardson <jules.richardson99 at> wrote:
>> On 05/03/2015 03:48 PM, Sean Caron wrote:
>>> I have seen almost anything once on Sun machines :O Are you testing with
>>> all cables disconnected just power and serial terminal? I have seriously
>>> seen a bad network cable cause mysterious hangs on a SS10 once...
>> Yeah, initially I just had serial and power hooked up, but because it seems to be defaulting to a network boot I did try connecting it up to my LAN too, but with no luck.
>>> You've tried some of the other usual troubleshooting stuff like swapping
>>> out/around some of the memory, removing Sbus cards, etc?
>> Not yet, but will do so.
>> I did just attack the PROM module with a dremel and so am now running with good battery voltage via an external battery (but at this stage it still throws up an "The IDPROM contents are invalid" message, of course)
>> I'm suddenly wondering if the serial port is fried. It's possible that I've only ever run this machine with keyboard/rodent/monitor attached, not via serial console, and a hardware fault on the rx side would explain the symptoms. I'll drag the necessary bits out of the basement and see if that changes anything (this room is rapidly filling up with vintage crap ;-)
>> cheers
>> Jules

More information about the cctech mailing list