Texas Instruments CC-40 won't boot

Chris Osborn fozztexx at fozztexx.com
Sat May 2 16:26:12 CDT 2015

Picked up a TI CC-40 and it’s much smaller than I expected. I thought it was going to be the same size as a TRS-80 Model 100. I mostly got it because I wanted to try out the BASIC on it so I could update the list of computers with BASIC in ROM that I started on Wikipedia.


As soon as I got it I popped in some batteries and turned it on, and I was able to enter a one line BASIC program and run it. Then I pushed the OFF key and since then it won’t boot up at all, it just gives me half a screen of black squares. Thinking maybe I had put partially dead batteries in it, I replaced them with fresh ones and same thing. I also pulled the batteries and tried powering it up from the DC input jack, still no go. When it’s stuck like this the OFF key doesn’t do anything and neither does the little reset button next to the spacebar.

I’ve looked around for a service manual and haven’t turned up anything. Did my RAM chips go bad? Did the ROM go bad?

Here’s a pic of the CC-40 and an M100 next to it for scale:


Follow me on twitter: @FozzTexx
Check out my blog: http://insentricity.com

More information about the cctech mailing list