Testing a 74S240

Rob Jarratt robert.jarratt at ntlworld.com
Sun May 1 05:37:31 CDT 2022

I am embarrassed to report that after trying all the suggestions etc, I then
realised that I had connected the enable signal to pin 9 and not 19. I knew
it was 19, I knew where 19 was, but for some unfathomable reason I connected
it to 9 instead, despite checking multiple times. The original chip works. 

Sorry for the noise.



> -----Original Message-----
> From: Guy Dunphy <guykd at optusnet.com.au>
> Sent: 01 May 2022 01:22
> To: rob at jarratt.me.uk; Rob Jarratt <robert.jarratt at ntlworld.com>; General
> Discussion: On-Topic and Off-Topic Posts <cctalk at classiccmp.org>
> Subject: Re: Testing a 74S240
> At 11:25 PM 30/04/2022 +0100, you wrote:
> >In trying to fix my M7133 CPU from my 11/24 I thought I had identified
> >a failed 74S240. However, when I replaced it (while adding a socket),
> >the fault remained. So, I guess the original chip may not be faulty. I
> >decided to test the original chip on a breadboard to see if it is OK.
> >This is where I got rather confused.
> >
> >
> >
> >I used a bench PSU, obviously connected Vcc to +5V and GND to the
> >negative terminal. I connected pin 19 (the active low Enable ) to GND.
> >And then I tested the particular pair of pins, 13 and 7. I did not
> >connect any of the other pins. However, pin 7 seemed to hover around
> >0.6 to 0.8V, no matter what I did with pin 13. I tried it with the
> >replacement 74S240 and got the same result. I tried a second
> >replacement 74S240 which had never been installed on the M7133 in case
> >something on the CPU board was damaging it, and got the same result.
> >
> >
> >
> >I looked at the M7133 schematic and saw that pin 19 is connected to GND
> >by a 180R resistor. I don't have one of that value so I tried a 220R.
> >My understanding is that the resistor isn't completely necessary, but I
> >tried anyway. However, the results were identical. I added a 220R to
> >the input on pin 19 just in case, again to no avail.
> >
> >
> >
> >I noticed that the chip (original and replacement) was drawing
> >100-110mA from the bench PSU, which seems a bit high.
> As others have mentioned, the supply current is normal. These are fast,
> power devices.
> When you say 'breadboard', what do you mean? Is it one of those blocky
> things with rows of holes with metal connecting fingers inside?
> Those have a lot of capacitance between rows, and with fast 74S logic and
> inverting buffers chip like the 74S240 that can be a problem. Also I bet
> didn't bother with a supply decoupling 0.1uF ceramic directly between Vcc
> and Gnd at the IC.
> So be aware that you may have a circuit oscillating at something above
> 20MHz, and your multimeter will just be showing averages.
> To avoid this, add the supply cap and tie all unused inputs directly to
> With the input you are interested in, tie to Gnd or to Vcc via a 1K
> All with _short_ wires. Also with your multimeter (on Volts range) it's a
> idea to have a 1K resistor in series with the probe tip AT THE TIP.
> your meter lead is a nice radiating antenna, and can cause oscillations
> that less than ideal breadboard.
> The resistor won't affect voltage readings.
> Old 74xx logic (mostly) doesn't have these problems, and people used to
> get confused when much faster logic seems to be behaving weirdly.
> At least the IC won't blow up. I had an interesting learning experience
> first time I got hold of a 74AC series 20 pin buffer chip. I blithely
> breadboarded it with just the power rails and turned on +5V.
> BANG! the die exploded. Blew a nice big crater in the plastic.
> Turns out with the fully CMOS inputs, they will float around in the zone
> between 0 and 1, which causes the very powerful output drivers to draw
> huge current as both the upper and lower drivers turn somewhat on. Times
> eight... Instant silicon vaporization.
> After tying all the inputs to valid logic levels, no more explosions.
> Guy

More information about the cctalk mailing list