Firing up the pdt11

Chris Zach cz at
Sun Oct 11 20:14:05 CDT 2020

Well, by "location" I mean there are plugs on the controller board for 
PD0 (typically called the "top" drive) and PD1 (typically the "bottom" 
drive). My test swapped the cables so the top drive was using the PD1: 
logic on the board and the "bottom" was using the PD0 logic. In that 
situation the PD1: channel with the top drive worked so the problem is 
not in the logic board.

However I may have figured out a clue: When I try to boot the pdt11 on 
the good drive (now PD0: again) with the door open the drive makes a 
quick BRAAP noise in the head positioning motor and it fails. It does 
not drop the head pad servo. When I close the door the drive clicks in 
the servo and boots away.

However on the bottom drive it always does the BRAAP regardless if the 
door is open or closed. So I looked at the spare 8 inch drive: There is 
no "disk present" switch or anything but there *IS* the sector lamp and 
CDS cell. So the big question:

Maybe the RX01/PD logic looks for the sector pulse signal to determine 
if a disk is in the drive? That would explain how the controller "knows" 
there is no disk.

And a bigger question: Is that an LED or a light bulb that lights up the 
sector pulse CDS cell (I can see the detector is a CDS, I recognize 
those from my 150-in-one Tandy days). If so maybe it burns out?


On 10/11/2020 8:17 PM, Richard Pope wrote:
> Chris,
>      I would like to get a clarification on this. Does either drive work 
> fine in the PD0 position or does the drive that was not working in the 
> PD1 position not work in the PD0 position? You said that the spare drive 
> that you put in the PD1 position also does not work. I would try it in 
> the PD0 position and see if it works or not. Would you please let me 
> know on these items?
> GOD Bless and Thanks,
> rich!
> On 10/11/2020 7:11 PM, Chris Zach via cctalk wrote:
>> I'm back to working on the PDT11/150 again, the bottom floppy is 
>> weird: It doesn't read rx01 disks, period. Top one is fine. So I tried 
>> swapping all of the connectors on the control board so the top one was 
>> PD1: and the bottom was PD0: Sure enough the top drive works fine as 
>> PD1: and bottom is still dead so it's a drive issue.
>> Pull the drive, put in a spare, button it up, and sure enough it still 
>> doesn't work. Any ideas?
>> Also I recall my MiniMinc/150 (which is in parts in my shed) had EIS 
>> and FIS, but this one only reports FIS. Did DEC make pdp11/03 
>> expansion chips that only had FIS?
>> C

More information about the cctalk mailing list