SPARCstation 20 with SCSI2SD

ethan at ethan at
Sun Nov 25 21:14:35 CST 2018

> Well, got the last problem solved rather quickly: I tried using 512 byte
> sectors for the emulated CDROM instead of SCSI2SD's default of 2048 for a
> CDROM, and that did the trick. Working my way through the SunOS 4.1.3
> installation process now on the SS-20.

Was just thinking the 512 byte thing might be an issue. Early Toshiba 
Cd-ROMs had a solder jumper that would switch this, and is was needed for 
some early systems. SGI Indigo R3000 and below was one, and I guess Sun 
was another. I think NeXT also requires the 512 byte block CD-ROM.

Since you said QEMU, you are emulating this? If on the real hardware, is 
the NVRAM memory dead? Looks like it doesn't know what kind of hardware it 
is. Real hardware will loose nvram battery and need to be replaced and 
reprogrammed, or you can file it down and jumper a battery into it.

There is also probably a bunch of environment variables in the NVRAM as to 
the CD-ROM SCSI path and OS scsi path and stuff on the Sun. It's been a 
long time since Sun boxes for me, so unfortuantely I've forgotten a lot of 
it. But if it's all reset or non-existant it could be a source of issues 
if my memory is right (It definitely is on SGI hardware.)

: Ethan O'Toole

More information about the cctalk mailing list