New to System/36

alan at alan at
Sat Nov 10 20:59:34 CST 2018

Good news.  At our AHCS club meeting today, someone there just happened 
to have a keyboard with the correct code page and connector for my 
terminal.  Yvan was correct in that the terminal doesn't operate at all 
without one.  With the keyboard, everything came alive.  The machine 
IPL'd just fine into a login screen after about 8 minutes. We were able 
to get into the disk editor, recover the username and password, and 
log-on successfully.  So I apparently do have a working set of 1x 30 MB 
and 1x 60 MB hard disks.  Password and data security was not active and 
there were only 3 total users.  The CMAS accounting software menu or 
library - default for the other users - was not found.  I'm assuming it 
was maybe deleted when the machine was taken out of service.  But the 
system is functional.

The BASIC, FORTRAN, and COBOL languages were not installed. But we did 
try writing a Hello World program in RPG II but it failed to compile 
correctly!  It was fun trying.  The default line level editor was about 
the worst thing I've ever used in 40 years of pounding on a keyboard - 
and I've seen a lot of bad in that time.

I still would like to get a set (or two) of later release SSP disks as 
as well as archive and reimage some of the application software I have.  
I'll email Mcguire.  But if anyone else has experience in imaging IBM 
mid-range floppies, I'd love to get some more advice.


Alan H.

On 2018-11-10 15:00, alan--- via cctalk wrote:
> Thanks Yvan.  I was hopeful when the terminal output the standard 
> status
> line at the bottom with an 08 code in the lower right above the line 
> and
> a blue K in the bottom center below the line - which I assumed was a
> keyboard not present error.  I could not find the address switch
> anywhere on that terminal to configure it.  The previous owner said it
> was the system console so I assumed it was already set for address 0
> 'somehow'.
> I also assumed the hard drives were bad or the load on them was corrupt
> when never saw any terminal output after nearly 30 minutes.  First 
> thing
> I should see is the numerical countdown after 4-5 minutes, correct?
> I have only disk 1 of SSP 3.0.  When I try to start the machine using
> function 3/1000, it throws SRC 210F which the code-manual describes as
> not being able to find valid sector marks.  Not sure if it's a problem
> with the media or the drive at this point.
> The machine came from a young man who didn't know much about it.  He
> said it was his fathers and it worked last time it was in-use.  But 
> that
> was at least 15 years ago.  It has been siting indoors for that time.
> So there is hope.  The bearings in the hard drives sound pretty bad.
> But during what I assume is the normal IPL (with no terminal output),
> the drives are spun-down and then back up again in sequence about 1-2
> minutes in.  I can also hear the heads engage and vigorously move about
> a minute past that for a while - which I assume is the IPL trying to
> load the CPU kernels - but I obviously never get to the IPL sign-on.
> -Alan H.
> On 2018-11-10 14:44, Yvan Janssens wrote:
>> You will need the keyboard. Those terminals usually don't come up 
>> without it. Good news tho if the keyboard has been nicked, the 
>> protocol is compatible-ish with PS/2. I have successfully used 
>> $generic_ps2_keyboard with the right plug for it. Make sure to not hit 
>> the Windows key (or any other 'new' keys) - you'll lock up the 
>> terminal's firmware.
>> You will also have to configure the terminal to use address 0 - Twinax 
>> busses have an address range of 0-7 and you need bus 0, address 0 for 
>> the console.
>> Generally speaking, bringing up the system is similar to bringing up 
>> early AS/400s.
>> /y
>> On Sat, 10 Nov 2018 at 19:59, alan--- via cctalk 
>> <cctalk at> wrote:
>>> Just picked up an IBM System/36 5362 last night.  It is in pretty 
>>> good
>>> physical condition with just a few minor scratches - other than 
>>> needing
>>> a thorough cleaning.  It has 2 60 MB hard disks in the unit.  Not 
>>> sure
>>> of the RAM capacity.  Missing the the mode hard key.
>>> A few of us tried to get it running tonight.  It came with a 3179
>>> twin-ax terminal but no keyboard.  We connected the terminal via a
>>> twinax cable direct from port 0 to the terminated Y adapter on the
>>> terminal.  Never got any output on the terminal at any time other 
>>> than
>>> the fairly empty status line.  The S/36 front panel console light did
>>> illuminate after we connected the terminal.  The key was locked to
>>> Normal but we were able to by-pass it with a jumper to get it into
>>> Service mode.  The media that came with it only had disk 1 of an SSP
>>> release and we could not get that to IPL from floppy (mode 3 / panel
>>> 1000).  It stepped the head motor forward and back a couple times,
>>> engaged the head, then immediately threw an error code.
>>> Any idea where I can get an SSP release for the S/36 5362 and how to
>>> write it to 8" floppies?  Also where I might find a keyboard for the
>>> terminal and what can be done if anything to gauge the health of the
>>> hard drives?
>>> -Alan H.

More information about the cctalk mailing list