RL02 Spinup fails

Aaron Jackson aaron at aaronsplace.co.uk
Sat Nov 11 10:58:41 CST 2017

It sounds silly but I don't actually have access to a Windows machine,
but PD11GUI looks nice.

I managed to boot into XXDP today using tu58em and ran the RLV12
controller test. It seems though that the version of XXDP I loaded does
not support the 22bit address (17774400) and defaults to the 16bit
address (174400) so it just shows errors for everything.

VTserver does seem to default to the 22bit address, and I can tell this
because the error for vtserver (as included in my previous email) shows
the output of the CSR (142205). I've also checked this value manually
from ODT and it comes out the same after trying to read.

b 1 1 0 0 0 1 0 0 1 0 0 0 0 1 0 1 = o 142205

>From what I can tell, this decodes to, from right to left:

0     Drive ready, yes
1-3   Command function code (0,1,0 = get status)
4-5   Extended address bits. I don't know what this means.
6     Interrupt enable, no.
7     Controller ready, when this gets cleared it runs the cmd in 1-3.
8-9   Indicates the current drive. I've only one connected, hence 0.
10-13 Error Code (0,0,0,1 = operation incomplete)
14    Drive Error, yes unfortunately.
15    Composite Error, indicates one or more error bits are set.

The RL02 technical manual says to figure out why a drive error occurred,
I can execute a get status command (?) and then perform an MPR read
(?). So while I don't know how to do that, the error could be one of the
following (apparently)

- spin error. I assume it's not this because the ready light is on?
- seek time out. Maybe this?
- write lock. Only set when the drive is write protected.
- current head error. Set when write current is detected while reading.
- write data error. Set when no transitions are detected during writing.

So, pretty confused.



william degnan via cctech writes:

> I have successfully built a rl02  disk using pdpgui on a windows XP laptop,
> the newer version works on window 10.  All you need other than the software
> is a serial card like a m7800.  Pdpgui acts as a gui.  Do you have a m9312
> rom/terminator card with a terminal console rom?
> Bill Degnan
> twitter: billdeg
> vintagecomputer.net
> On Nov 11, 2017 7:04 AM, "Aaron Jackson via cctech" <cctech at classiccmp.org>
> wrote:
>> Well, some progress.
>> It seems that a terminator is not required so long as the cable is VERY
>> short. The controller RLV12 controller appears to have a few termination
>> resistors on it anyway. There is no fault light appearing and the drives
>> spin up fine. Mine cable is less than 20cm and the PDP is sitting just
>> on top of the drive.
>> I can see that the drive is communicating because the lsb of the csr
>> changes flips between 0 and 1 when I load and unload the drive.
>> I wanted to try and dump the disks using vtserver, but when I run the
>> copy program I end up with the following
>> ]] Enter name of input record/device: rl(0,0,0)
>> ]]
>> ]] Can't get rl(0,0,0) sts
>> ]] rl(0,0,0) err cy=0, hd=0, sc=2, rlcs=142205, rlmp=0
>> ]] rl(0,0,0) error reading labelsector
>> ]] Enter name of input record/device:
>> The same happened on both packs - they have both been cleaned and look
>> as though they are in good condition. The heads have been cleaned too.
>> Given that the drive appears to be communicating with the PDP-11, where
>> might this problem come from?
>> Thanks,
>> Aaron.
>> Aaron Jackson via cctech writes:
>> > Hi everyone,
>> >
>> > I have managed to hook up an RL02 drive to my PDP-11 (thanks to Dave
>> > Wade for the drives) . This took me longer than I thought it would - I
>> > tried with a flat ribbon cable with a DIY terminator going straight into
>> > board , but couldn't get it to work. Removed the terminator, and the
>> > fault light turned off. So that's positive.
>> >
>> > I tried to load a cartridge, which I had cleaned, inspected and
>> > generally appears to be in good condition. It started to spin up and I
>> > could hear it getting faster, but after 30-40 seconds the fault light
>> > returns. I made a short video demonstrating this:
>> >
>> >          https://www.youtube.com/watch?v=japwBBodO8U
>> >
>> > According to the manual the fault light can appear for the following
>> > reasons:
>> >
>> > - Drive select error... Surely this would come on at the start?
>> > - Seek time out error... I'd have to hear the heads move first
>> > - Write current in heads during sector time error... Same as above
>> > - Loss of system clock... The fault light would be on from the start.
>> > - Write protect error... I don't think it got that far
>> > - Write data error... Same as above
>> > - Spin error... Is this the only remaining fault?
>> >
>> > So could the only cause be a spin error? I am wondering if the belt is
>> > slipping or something like that?
>> >
>> > Can anyone offer some advice?
>> >
>> > Thanks,
>> >
>> > Aaron.
>> --
>> Aaron Jackson
>> PhD Student, Computer Vision Laboratory, Uni of Nottingham
>> http://aaronsplace.co.uk

Aaron Jackson
PhD Student, Computer Vision Laboratory, Uni of Nottingham

More information about the cctalk mailing list