RL02 Spinup fails

David Collins davidkcollins2 at gmail.com
Mon Nov 6 17:28:41 CST 2017

I’m more used to working on HP drives of this type but it sounds to me like you are getting a seek Time Out. It sounds like the motor spins up to speed  and the head load is being initiated. there should be a carriage unlock (I assume there’s a lock solenoid) and the carriage should start to move.  If the drive doesn’t sense movement of the carriage away from the home position after a certain time  (is there a carriage home optical sensor or micro switch to detect carriage home?) it could give a seek error, even before it gets near the disc. 

It could be that locking plate Henk mentioned , the lock solenoid not pulling in, or a problem with power getting to the actuator to drive the heads out. 

That’s how an HP drive does it anyway. 

David Collins

Sent from my iPad

> On 7 Nov 2017, at 7:41 am, Henk Gooijen via cctalk <cctalk at classiccmp.org> wrote:
> Van: Aaron Jackson via cctalk<mailto:cctalk at classiccmp.org>
> Verzonden: maandag 6 november 2017 19:15
> Aan: cctech at classiccmp.org<mailto:cctech at classiccmp.org>
> Onderwerp: RL02 Spinup fails
> Hi everyone,
> I have managed to hook up an RL02 drive to my PDP-11 (thanks to Dave
> Wade for the drives) . This took me longer than I thought it would - I
> tried with a flat ribbon cable with a DIY terminator going straight into
> board , but couldn't get it to work. Removed the terminator, and the
> fault light turned off. So that's positive.
> I tried to load a cartridge, which I had cleaned, inspected and
> generally appears to be in good condition. It started to spin up and I
> could hear it getting faster, but after 30-40 seconds the fault light
> returns. I made a short video demonstrating this:
>         https://www.youtube.com/watch?v=japwBBodO8U
> According to the manual the fault light can appear for the following
> reasons:
> - Drive select error... Surely this would come on at the start?
> - Seek time out error... I'd have to hear the heads move first
> - Write current in heads during sector time error... Same as above
> - Loss of system clock... The fault light would be on from the start.
> - Write protect error... I don't think it got that far
> - Write data error... Same as above
> - Spin error... Is this the only remaining fault?
> So could the only cause be a spin error? I am wondering if the belt is
> slipping or something like that?
> Can anyone offer some advice?
> Thanks,
> Aaron.
> I saw the video.
> It seems that the motor runs and the disk spins up.
> As Tony suggests, check the possible fault sources.
> One obvious fault: is the head still locked? That’s the small
> metal plate fixed with one screw in the top right corner (IIRC).
> Long ago, I tried to run RK07 drives of the RK611 controller
> using a flat cable (not shielded), length 1 meter. The XXDP diags
> gave all sorts of errors that went away after I found the correct
> (shielded) cable BCxx.
> You are correct, the fault light will go on immediately when the
> drive is no connected to the controller. I *think* READY should
> come up even when no terminator is installed.
> One other possible fault. Are you sure the RL02 disk pack is OK?
> If it has been wiped with a magnet, it has become useless as a
> disk pack, but maybe useful for a “wall clock platter”. READY will
> never light up, and possibly there is a time out.
> Not sure you can *hear* the head (carriage) move though …

More information about the cctalk mailing list