RL02 Spinup fails

Aaron Jackson aaron at aaronsplace.co.uk
Mon Nov 6 13:07:57 CST 2017

william degnan writes:

> On Sun, Nov 5, 2017 at 12:43 PM, Aaron Jackson via cctech <
> cctech at classiccmp.org> wrote:
>> Hi everyone,
>> I have managed to hook up an RL02 drive to my PDP-11 (thanks to Dave
>> Wade for the drives) . This took me longer than I thought it would - I
>> tried with a flat ribbon cable with a DIY terminator going straight into
>> board , but couldn't get it to work. Removed the terminator, and the
>> fault light turned off. So that's positive.
>> I tried to load a cartridge, which I had cleaned, inspected and
>> generally appears to be in good condition. It started to spin up and I
>> could hear it getting faster, but after 30-40 seconds the fault light
>> returns. I made a short video demonstrating this:
>>          https://www.youtube.com/watch?v=japwBBodO8U
>> According to the manual the fault light can appear for the following
>> reasons:
>> - Drive select error... Surely this would come on at the start?
>> - Seek time out error... I'd have to hear the heads move first
>> - Write current in heads during sector time error... Same as above
>> - Loss of system clock... The fault light would be on from the start.
>> - Write protect error... I don't think it got that far
>> - Write data error... Same as above
>> - Spin error... Is this the only remaining fault?
>> So could the only cause be a spin error? I am wondering if the belt is
>> slipping or something like that?
>> Can anyone offer some advice?
>> Thanks,
>> Aaron.
> At that point, for the time it takes the drive to be ready from a load
> should be about 15 seconds.    For you the Fault light comes on instead.
> If I turn on my drives but leave the computer (11/40) off, the fault light
> comes on immediately.  If I then turn on the computer the fault light will
> turn off, although I may have to press load first and if so it will turn
> off after a few seconds.    It's independent of the LOAD/READY lights
> based on this informal comparison I'd venture you have a drive issue.  I am
> not 100% sure what your termination situation is.  I have two drives, one
> terminated but it's with a DEC terminator on the bottom port of drive 1.
> The cable comes from the computer into drive 0.  I have a cable going from
> drive 0 port 1 to drive 1 port 1.
> Bill

The only thing I can think of with the terminator is that by using the
bulkhead connectors on the back you would end up with something like

		      	    |--- logic board
  pdp11		      rl02  |
	      terminator ---|

but I built my terminator directly onto the end of a ribbon cable, and I
realised that it is actually slightly different. More like this:

				 |	   |
                              logic    terminator

I wouldn't thought it would matter but maybe timing is very sensitive. I
can imagine something like this causing an issue with 10base2 networking
for example.

Thanks for the information.


More information about the cctalk mailing list