H7861 PSU issues

Aaron Jackson aaron at aaronsplace.co.uk
Wed Nov 1 13:24:49 CDT 2017

Picked up a few 555s and sockets and now it works! I am very
happy. Going from not knowing how switch mode power supplies work, to
watching some YouTube videos, and then finally being able to debug the
problem and fix it was a lot of fun.

I wonder what will die next.



Rob Jarratt writes:

> I had a dead 555 on a completely different PSU, so it could be worth
> checking. I socketed it when I replaced it so it was easy to replace again.
> Also, just because a capacitor doesn't appear swollen or show signs of
> leakage, it seems that this doesn't necessarily mean that it doesn't need
> replacing. In yet another PSU that I repaired recently, replacing the
> capacitors fixed it, although in the end I think the one that really fixed
> it was showing signs of leakage. On a lot of caps that I replace they show
> no leakage signs, but I do see a bit of a deposit on the negative terminal,
> I am not sure if this is a sign of any kind of problem.
> Regards
> Rob
>> -----Original Message-----
>> From: cctech [mailto:cctech-bounces at classiccmp.org] On Behalf Of Aaron
>> Jackson via cctech
>> Sent: 31 October 2017 21:26
>> To: cctech at classiccmp.org
>> Subject: Re: H7861 PSU issues
>> Just had another look after watching a video about how switch mode power
>> supplies work.... On the small control board connecting to J4, there are
> two
>> D44Q1 transistors. As expected, there is about 65KHz going into the base
> of the
>> transistor for the 5V side. However, there is no signal going into the
> base of the
>> transistor for the 12V side, from pin 3 of the 555. So, it looks like the
> problem is
>> coming from around here. I measured the suspicious components around the
>> 555 and they seem fine.
>> How likely is it that the 555 is dead? There is 10v going into pin 8,
> which I
>> believe is correct.
>> Thanks,
>> Aaron.
>> Aaron Jackson writes:
>> > Hi everyone,
>> >
>> > I've been trying to figure out what is wrong with the 12V rail on my
>> > H7861 (BA11-S) power supply. It's showing about 4.2V. The 5V rail is
>> > spot on.
>> >
>> > Page 39 of the following schematics is the main part board of the PSU.
>> > http://bitsavers.org/pdf/dec/qbus/MP01233_BA11-S_schem_Mar81.pdf
>> >
>> > Going into the collector of Q3 is about 80V coming straight from T2 (I
>> > think I measured it at about 100Hz), but the emitter is putting out
>> > the 4.2V, which is the same as the base voltage and output voltage. I
>> > tried replacing this transistor because the hFE was about 80 and a
>> > good one was about 120. Unfortunately it didn't do anything.
>> >
>> > None of the capacitors look swollen and I don't see any leakage. There
>> > is a smaller board which I think goes into J4. The 12V side seems to
>> > have a 555 timer and adjusting the pot doesn't change the voltage at
>> > all.
>> >
>> > My understanding of switchmode power supplies is very poor. Does
>> > anyone have some pointers on what to check or what might be the possible
>> cause?
>> >
>> > Hopefully I can get my PDP up and running again... Only got about 20
>> > minutes use out of it.
>> >
>> > Thanks!
>> >
>> > Aaron.
>> --
>> Aaron Jackson
>> PhD Student, Computer Vision Laboratory, Uni of Nottingham
>> http://aaronsplace.co.uk

Aaron Jackson
PhD Student, Computer Vision Laboratory, Uni of Nottingham

More information about the cctalk mailing list