Data General NOVA 4/C help

Jay Jaeger cube1 at
Tue Oct 20 16:54:26 CDT 2015

On 10/20/2015 2:45 PM, Henk Gooijen wrote:
> With thanks to Bruce, Jay and Rod, good news, although something
> has gone wrong first. Learned a few things!  Long story ...
> As I did not see anything on the Dasher D200 terminal screen, I first
> checked the cable, assuming that the terminal did not develop issues
> in the years being stored in the attic.
> The cable checked out fine, and thus I now know which wires are RxD
> and TxD (the cable is just 3 wires, no hardware handshake).
> After connecting TxD to RxD anything typed on the keyboard appears on
> the screen. So indeed, the terminal is OK.
> Moving to the "UNIVERSAL LINE MULTIPLEXER PADDLE BD". Lots of wires are
> soldered to this paddle board, but as far as I can see none of those
> wires goes to any pin of the card edge connectors of slot #1, the NOVA
> processor. I figured that perhaps traces on the backplane lead from
> slot #1 to another slot, so I had a better look at the paddle board.
> It has 5 identical rows of pins. Each row is 13 pins with pin 4 (or 10
> depending where you start counting) removed.
> Long story short, I did not see any signals on any pin when the NOVA is
> reset.
> Using the doc that I got from Bruce (tnx agn!) I tried to find signals
> or voltage levels that might be something "RS-232-ish".
> Hooked up two thin test wires (with small hooks). One on GND, the other
> on the pin that would carry TxD. Stepping to the front of the computer,
> where I could press the RESET button, and look at the scope screen.
> RESET ... nothing, bummer.
> Back to the rear side of the computer to hook up another pin ... smoke!
> Smoke was coming from the GND test hook. Power off!
> The hook plastic was molten and that produced the smoke. I could remove
> the hook from the pin, but the hook is gone and the test hook is gone.
> What went wrong?
> After a few minutes I came to the conclusion that the pin that I assumed
> to be GND was not GND, but something else, and most likely a power supply
> pin. Looking again at the schematic drawing, I saw my error :-/
> The NOVA has two card edge connectors, seeing from the rear, the left
> connector is "A" and the right connector is "B". Further, each connector
> has two rows of pins. In my ignorance of DG, I thought that the top row
> of pins was "A", and the bottom row of pins is row "B". And each row has
> 100 pins ... dumb, dumb!
> A simple count from 1 up, would have shown that one row has only 50 pins!
> Each connector has all *odd* pins on the upper row and all *even* pins on
> the bottom row.
> Soooo, what I thought to be B99 (=GND) is actually pin A98, and that is
> +5V.  It is a good thing that my test leads and hooks are small, so in
> case of high currents the power supply will "win", the hook/wire "loose".
> As the computer did not do anything "different", I hoped the power supply
> could handle the "semi" short circuit.
> With the new insight of how you should count the pins, I had another look
> at the BERG header. The GND, RxD and TxD aligned with appropriate pins on
> the top row, last series of pins of connector A. It could well be that
> the connector (as it was hooked up when I picked up the machine) was not
> correct! Also, I seem to remember the system originally had *two* D200s,
> but I got only one terminal. Possibly the hooked up terminal was "the
> other terminal", not the console terminal ... and the console terminal
> would have been connected on the pins of connector A slot #1.
> Hmmmm, let's try that. The signals would match as the RxD pin of the
> terminal would connect to backplane pin A85 which is TxD, etc.
> Another long story short ... :-)
> Terminal on, waiting until the screen shows some background light, then
> NOVA on (the rest stays off). Hurray!  I see an "O" appearing on the
> screen and a second or so later, the letter "K" and on the next line
> "!000000" and another line with "!"  This is exactly what should happen.
> Getting bold now. Trying to boot from disk. So, I switched on the disk
> drive. With my ear against the front panel, I can hear a sound that could
> be a spindle drive. Then a rather loud "humming", a "click", the humming
> stops and then I can still hear the spindle ... but the READY LED is on.
> So, I RESET the NOVA. "OK !000000 !", but that's all, no joy. "OK", let's
> try the floppy disk. I removed the front panel to switch the floppy drive
> to be the boot device ... it already is the boot device!  No wonder that
> nothing happened, because I had no floppy in the drive! Inserted the
> "startup" floppy ... nope, no good. As the front cover was removed and
> the disk was spinning (I assumed), I set the switch in the other position
> so that the hard disk is boot device. RESET the NOVA again. The READY
> LED flashes a few times and I get the text "FILENAME ?" on the screen!
> I guess that the startup automatically starts the accounting application
> as that program asks for a (customer) account file to be opened.
> I had a glance over the doc that came with the system, so I "knew" a file
> name that I could enter ... DOSINIT. That worked! However, the program
> asks for a drive identifier. Not knowing what could happen (wipe disk...)
> I aborted the program and switched off the disk and then the NOVA.
> All in all a well-spent evening. With good feeling I closed my "museum"
> and went back home (to type this).
> - Henk


DOSINIT is the DOS disk initialization (file system setup, if you will)
 program, so it is good that you stopped.  ;)

FILENAME? is the normal DOS prompt, asking for what system file to boot
from disk.  It is not coming from the accounting program.

Instead, try just hitting return in answer to the FILENAME ? prompt -
that will boot DP0:SYS.SV - the default generated operating system.
Responding to the prompt with just "SYS" (no quotes) would do the same
as would DP0:SYS .

See appendix E of 093-00201-00 available on bitsavers (see below).

I have quite a few manuals as well.  Versons of some/many of them can be
found on bitsavers in the directory: .../pdf/dg/software/

001035	DG		069-000002-00	NOVA, Eclipse	MANUAL	Introduction to the Real
Time Disk Operating System (RDOS)	P	BASEMENT				1978	

001043	DG		069-000022-01	NOVA, Eclipse	MANUAL	Learning to Use Your
RDOS/DOS System	P	BASEMENT				1979	

001112	DG		093-000075-08	NOVA, Eclipse	MANUAL	Real Time Disk Operating
System (RDOS) Reference Manual	P	BASEMENT				1979		

001125	DG		093-000105-02	NOVA, Eclipse	MANUAL	RDOS User's Handbook	S
BASEMENT				1975				

001131	DG		093-000109-01	NOVA, Eclipse	MANUAL	RDOS/DOS Command Line
Interpreter User's Manual	P	BASEMENT				1978	

001166	DG		093-000188-02	NOVA, Eclipse	MANUAL	How to Load and Generate
Your RDOS System	P	BASEMENT				1979				

001190	DG		093-000201-03	NOVA	MANUAL	Disk Operating System (DOS)
Reference Manual	P	BASEMENT				1979						

001199	DG		093-000222-01	NOVA	MANUAL	How to Generate Your DOS
System	P	BASEMENT				1979			

So at least now you have some manual numbers (093-......) to hunt for.


More information about the cctalk mailing list