Troubleshooting a 286.. oscope level!

ethan at ethan at
Sat Oct 3 15:44:02 CDT 2015

> Make/model? (Just in case anyone knows it and knows if it has any 
> quirks).

Yamaha C1, one of these:

> That would worry me. If one bit of the BIOS program (as opposed to 
> copyright messages)
> is wrong then the machine could well behave very oddly. Having found 
> that I would want toget a known-good dump of the BIOS into EPROMs.

It doesn't behave at all. The LCD backlight never comes on, and it always 
thinks that it's in external video mode. There is a dip switch on the back 
to set this between internal and external display, and it never switches 
to internal. I don't have a CGA monitor, but I tried to cross wire a 
Commodore 1084S over to it and nothing.

>That's an odd failure too. Most times true bit-rot turns 0's into 1's. 
> Now assuming that first character should be 'C' (or 0x43), then in one 
> case it becomes 'P' (0x50) and in the other it becomes 0x9A. In neither 
> case is that simply setting bits that should be cleared. So perhaps 
> not bit-rot but some other failure of the memory device.

Hmm yea I just looked. I pulled a chip and put it in the reader. The first 
read looked similar, then it seems to be going downhill. The reader I have 
supports the device directly (ATMEL 27C256), and it's a Needham EMP-100. 
Just tried setting it to AMD and a few other brands but I don't think that 
changes the read speed or power or anything.

> OE/ might be something as simple and MemRd/ (Memory Read). Is it 
> bringing CS/ (chip select)
> low that often?

Yea the CS is staying active. Since it never really POSTS or brings up the 
LCD backlight, it never does a floppy seek. I'm guessing the CPU is stuck 
in an instruction loop or something, possibly because BIOS is damaged?

> A machine of that vintage may or may not 'shadow' the BIOS ROM -- that 
> is copy it into RAM for faster access. If it does, then it probably 
> won't access the ROM once the copy is complete (but is
> it completing the copy -- and detecting it has gone through all the 
> locations ?). If it doesn't (which
> is actually quite likely) then it will be running a program from ROM to 
> set up I/O devices and attempt
> to read the boot disk. Which means much of the processor activity _will_ 
> be reading the BIOS ROM.

I'll look through the manual to see if it has an option to shadow ROM 
BIOS. I remember that options on the later computers!

> When you drop into BIOS, is anything actually set?  Can you set the time, and get it to stick?

Never gets this far unfortunately.

> I have a Twinhead 386sx/16 I bought new, the only thing I've used it for in the past 20 years
>  is a serial terminal, and every time I go to boot it, I have to drop into BIOS, and configure
>  things, as the BIOS battery is long dead.

Yup, I've seen that. This machine has a rechargable battery set of 3 coin 
looking things in a nice pack that is separated from the motherboard and 
everything. Great design. It's a strange laptop format computer that has 
no battery option.

> Are you getting confused between the BIOS (the I/O drivers and bootstrap 
> in EPROM) and the 
> BIOS parameter table (often called the 'BIOS' or 'CMOS' (as it is stored 
> in battery-backed CMOS RAM) by the PC crowd)? I was under the impression 
> that the OP's machine didn't produce any display (does it? If so, what?) 
> and doesn't respond to the keyboard.

No display, the LCD actually never lights up. There is an option to switch 
between external CGA or internal LCD, no matter what setting the dip 
switch is set to it always says external display -- another hint that 
something is very wrong.

Thanks for the replies!

I'm trying to find someone with a working machine and going to ask them to 
run a bios dump utility. Not sure if it will work but short of finding a 
working specimin it's my next hope.

There is a 3rd Eprom in the machine, it's not a bios and it won't be 
readable by the bios dump util I found so another potential issue.

Ethan O'Toole

More information about the cctalk mailing list