RL02 Spinup fails

Aaron Jackson aaron at aaronsplace.co.uk
Fri Nov 10 17:31:32 CST 2017

Well, some progress.

It seems that a terminator is not required so long as the cable is VERY
short. The controller RLV12 controller appears to have a few termination
resistors on it anyway. There is no fault light appearing and the drives
spin up fine. Mine cable is less than 20cm and the PDP is sitting just
on top of the drive.

I can see that the drive is communicating because the lsb of the csr
changes flips between 0 and 1 when I load and unload the drive.

I wanted to try and dump the disks using vtserver, but when I run the
copy program I end up with the following

]] Enter name of input record/device: rl(0,0,0)
]] Can't get rl(0,0,0) sts
]] rl(0,0,0) err cy=0, hd=0, sc=2, rlcs=142205, rlmp=0
]] rl(0,0,0) error reading labelsector
]] Enter name of input record/device:

The same happened on both packs - they have both been cleaned and look
as though they are in good condition. The heads have been cleaned too.

Given that the drive appears to be communicating with the PDP-11, where
might this problem come from?



Aaron Jackson via cctech writes:

> Hi everyone,
> I have managed to hook up an RL02 drive to my PDP-11 (thanks to Dave
> Wade for the drives) . This took me longer than I thought it would - I
> tried with a flat ribbon cable with a DIY terminator going straight into
> board , but couldn't get it to work. Removed the terminator, and the
> fault light turned off. So that's positive.
> I tried to load a cartridge, which I had cleaned, inspected and
> generally appears to be in good condition. It started to spin up and I
> could hear it getting faster, but after 30-40 seconds the fault light
> returns. I made a short video demonstrating this:
>          https://www.youtube.com/watch?v=japwBBodO8U
> According to the manual the fault light can appear for the following
> reasons:
> - Drive select error... Surely this would come on at the start?
> - Seek time out error... I'd have to hear the heads move first
> - Write current in heads during sector time error... Same as above
> - Loss of system clock... The fault light would be on from the start.
> - Write protect error... I don't think it got that far
> - Write data error... Same as above
> - Spin error... Is this the only remaining fault?
> So could the only cause be a spin error? I am wondering if the belt is
> slipping or something like that?
> Can anyone offer some advice?
> Thanks,
> Aaron.

Aaron Jackson
PhD Student, Computer Vision Laboratory, Uni of Nottingham

More information about the cctech mailing list