SWTPC 6800 issues again

Brad H vintagecomputer at bettercomputing.net
Mon Nov 28 22:09:40 CST 2016

It tested good with my DVM when I first had it.. but the cap is original for sure... maybe I will invest in a new one even though it seemed ok.

Sent from my Samsung device

-------- Original message --------
From: "Ian S. King" <isking at uw.edu> 
Date: 2016-11-28  11:37 AM  (GMT-08:00) 
To: "General Discussion: On-Topic and Off-Topic Posts" <cctalk at classiccmp.org> 
Subject: Re: SWTPC 6800 issues again 

On Mon, Nov 28, 2016 at 8:22 AM, Brad H <vintagecomputer at bettercomputing.net
> wrote:

> Hey guys,
> You might recall a while back I was having issues where I'd have to power
> up/power off multiple times before I'd get the 6800 to start up correctly
> and give me the SWTBUG prompt.  What I did was remove an overwrought
> modified RAM board and replaced it with a more basic 4K board set to the
> $A000 range.  That worked great for a while, but not we're getting back to
> the situation where I power up many times and get either ? marks, a string
> of 4s, or some other random character.  I have to power off and on several
> times before I get the $ prompt.
> I figured out how to run a proper RAM diagnostic and no errors came back.
> I
> wasn't sure how to properly test the $A000 board -  I assumed I couldn't
> let
> the test test the address space used by the test program itself, so I set
> it
> to run from A07F to AFFF (I think I did that right, I set the MSB in A002
> to
> A0 and LSB in A003 to 7F, and for the upper limit MSB in A004 to AF and
> A005
> to FF).
> I'm wondering now if this is really a RAM problem or maybe something else.
> I don't think it's the serial card.. I've tried both the MP-C and MP-S and
> no change.
> I have an NOS MP-B2 motherboard here.  The 'check pins' on the molex
> connectors for the cards haven't even been cut.  I could set that up for
> testing although, being totally unused I'm hesitant about altering it.
> What
> do you think on that?
> Brad
My first question (and pardon me if this was addressed in your earlier
thread) is, have you checked the power supply?  If possible, use a scope,
but even a good DVM will tell you if you're maintaining voltage.  And if
the filter cap is the original, just replace it - they have a limited
lifespan.  I bought one from Digi-Key for $19.  Hope that helps -- Ian

Ian S. King, MSIS, MSCS, Ph.D. Candidate
The Information School <http://ischool.uw.edu>
Dissertation: "Why the Conversation Mattered: Constructing a Sociotechnical
Narrative Through a Design Lens

Archivist, Voices From the Rwanda Tribunal <http://tribunalvoices.org>
Value Sensitive Design Research Lab <http://vsdesign.org>

University of Washington

There is an old Vulcan saying: "Only Nixon could go to China."

More information about the cctech mailing list