SWTPC 6800 issues again

Brad H vintagecomputer at bettercomputing.net
Mon Nov 28 10:22:01 CST 2016

Hey guys,


You might recall a while back I was having issues where I'd have to power
up/power off multiple times before I'd get the 6800 to start up correctly
and give me the SWTBUG prompt.  What I did was remove an overwrought
modified RAM board and replaced it with a more basic 4K board set to the
$A000 range.  That worked great for a while, but not we're getting back to
the situation where I power up many times and get either ? marks, a string
of 4s, or some other random character.  I have to power off and on several
times before I get the $ prompt.


I figured out how to run a proper RAM diagnostic and no errors came back.  I
wasn't sure how to properly test the $A000 board -  I assumed I couldn't let
the test test the address space used by the test program itself, so I set it
to run from A07F to AFFF (I think I did that right, I set the MSB in A002 to
A0 and LSB in A003 to 7F, and for the upper limit MSB in A004 to AF and A005
to FF).


I'm wondering now if this is really a RAM problem or maybe something else.
I don't think it's the serial card.. I've tried both the MP-C and MP-S and
no change.


I have an NOS MP-B2 motherboard here.  The 'check pins' on the molex
connectors for the cards haven't even been cut.  I could set that up for
testing although, being totally unused I'm hesitant about altering it.  What
do you think on that?



More information about the cctech mailing list