Rod Smallwood rodsmallwood52 at btinternet.com
Fri Jun 3 07:22:38 CDT 2016

On 02/06/2016 19:19, Noel Chiappa wrote:
>      > From: Rod Smallwood
>      > Needless to say all of the locations I examined came up filled with
>      > zeros.
> Device registers will be in the range 17760000-17777776 (although toward the
> top you'd mostly see CPU registers). The RX02 controller (RX211) should be at
> 17777170-6.
>      > Although the monitor display says Unibus system. I suspect what I have
>      > is a CPU used in a Qbus system with a hacked monitor and boot eprom.
> Hmm. Well, the same physical board should work in either system (/93 or /94)
> - and I suspect the ROMs check to see if there's a UNIBUS adapter (KTJ11)
> there, and declaim the CPU board as a UNIBUS or QBUS, depending. (I.e. I
> would wonder if there are separate QBUS and UNIBUS ROMs.)
> That's because I have this bit set that there aren't separate /83 and /84
> versions of the KDJ11-B for the two busses, and I would think that the /93
> and /94 would likely be the same. (I should read the -B and -E manuals to
> confirm that.) And I don't think there are separate part numbers for
> KDJ11-E's for QBUS (/93) and UNIBUS (/94) systems.
> But I'm not familiar with the ROM contents, so I can't say for sure. When
> debugging broken hardware, I tend to ignore boot/diagnostic ROMs anyway, and
> stick to simply what the hardware does (as seen via ODT), as that's a) much
> less complex, and b) fully documented. (I don't know of any ROM listings, and
> I'm not about to disassemble them!)
> So if you can't see the RX211 registers from ODT, let me know, and we'll
> figure out what to try to see if the KTJ11 is working properly.
>      > For whatever reason they managed to disable the unibus  I/O
> I'm not sure you can (in hardware terms, that is - and clearly if there's no
> way to do it in the hardware, the software cannot do so)... although it could
> be broken.
>      > I have what I believed is a working 11/83 in my computer room
>      > I'm going to try my processor in there
> There's a section in the /94 maintainence manual (EK-PDP94-MG-001, available
> online) about upgrading an -11/84 to an -11/94; you might want to read that
> to see if there are any gothca's in terms of the cabling, etc. (The console
> cabling will be an issue, of course, since the KDJ11-B and KDJ11-E use
> different console connectors on the board - I'm talking about the other
> cables.)
> But AFAIK the KDJ11-E (/93 and /94) is a compatible upgrade to the KDJ11-B
> (/83 and /84), so your plan should work.
> 	Noel
      I'm not being looked after my two  granddaughters to-day so I have 
had a bit more time on the 11/94

Here's a summary

1. On switch on you get a screen as per the manual claiming to be 
Monitor V1.06
      It determines correctly if you have a UBA or not.

2.  This is then followed by a request to type a letter B for boot , L 
for list and so on.
       On my screen this is at the bottom in the manual its right under 
the text at the top.

3.  You can type any letter you like and it always goes to the same screen.
     Its a sort of all in one for the functions.  The functions all 
appear to work
      (I have screen shots I can send off list to anybody who is interested)

4. The manual shows something different.
    Typing  a letter should take you to a screen  for that function only.
    further choices should require another letter to be typed. In other 
    a typical hierarchical menu system.

5.  That's the first non standard item.

6.  Now we move onto the real issue. Invisible unibus controllers.

7. The Unibus adapter appears to pass all of its tests.
    I have two and they both perform the same.

8. The next slot to the UBA is an RX211 connected to an RX02 having an 
RT11 boot disk in Unit 0
      It is set to the standard addresses. Again I have two and the 
result is the same in both cases.
      On power down there is the usual clonk from the RX02 as the heads 
unload on power off.

  9.  The next three slots have bus grant cards and the last one has a 
bus terminator and an MLM.

10 There is a second unused and not connected back plane in the box.

11. Trying to boot (Its DY for RX02 but I have tried them all) returns 
the message no controller and the two digit   display, located on the 
I/O connector panel, and the one on the front  panel change from 04 to 
14 (boot error).

12. Now on to ODT.  ODT works and returns values from all locations. All 
that is except the registers on the RX211
       You just get a question mark in response to forward slash.

13. I have tried a couple of other controllers - same result.

13.  So where next?  I'd like to get both monitor and boot proms back to 
       Then at least the manual would be relevant.

!4. Its worth the effort to be able to run old PDP devices.



More information about the cctech mailing list