IDE knowledge anyone?

Oliver Lehmann lehmann at
Fri Dec 11 18:35:53 CST 2015

Chuck Guzis <cclist at> wrote:

> On 12/11/2015 01:26 PM, Oliver Lehmann wrote:
>> I now tried something different. I issued a "format track command"
>> and sent 512 bytes afterwards as described in the ata spec. The drive
>> does not respond with an error, and when I read the sector buffer
>> right afterwards, it contains the exact data I transfered after I
>> issued the format track command.
> Okay, this is not getting results.  I believe that a long way back  
> in the thread that you said that only one drive make+model exhibited  
> this issue--other drives worked fine.
> Right now, I can't find the post where you specified the drive.  Who  
> knows--I might have one.

Western Digital Caviar 31600 it is.

I'm waiting for a 32Port-LA (might take up to a month). When it is there
I'll continue debugging that issue and see what a MS-DOS does different
from what I do.

More information about the cctech mailing list