Z80 / Z84C Swap (Doh!)

drlegendre . drlegendre at gmail.com
Mon Aug 17 15:31:46 CDT 2015

Hey Jules,

Ah, so your O1 also has the weird screen artifacts prior to hitting
'return'? Weird.. wonder what's up with that?

I've only detected activity from drive A (LH side). It definitely does
spin, the LED lights up, but I haven't been able to detect any head
movement. You mention that the head on yours steps back & forth
(indefinitely?)  with no disk present - does it behave any differently when
the drive door is open vs. closed?

In any case, one of us needs to find boot media.. and put some copies in
the mail. I have one bootable CP/M machine, a Kaypro 10 - also an Epson
QX-10 is here, but iirc it had some issues booting last time I tried it.
Might be possible to write media for the Osborne on one of those? (Not
bloody likely, but a solution needs to be found).

Thanks again for passing this one along to me.. very thoughtful of you!

On Mon, Aug 17, 2015 at 3:22 PM, Jules Richardson <
jules.richardson99 at gmail.com> wrote:

> On 08/16/2015 09:48 PM, drlegendre . wrote:
>> I placed a disk in Drive A and upon pressing RETURN the display
>> immediately
>> stabilized and went into a loop printing "BOOT ERROR" on successive lines,
>> eventually scrolling the original boot message off the top of the display.
> Hey,
> I dug out that machine's 'twin', and it does the same there (just to
> verify that there's nothing odd about that behavior).
> It did not seem to even attempt seeking the disk - and it behaves the same
>> way, whether or not a disk is in Drive A. Tried this routine several
>> times,
>> with minor alterations, and always the same - straight to the BOOT ERROR
>> scroll and no other activity in the drive.
>> Drive LED was on in all cases.
> OK... behavior on mine (with no disk present) is that the drives spin, the
> heads step in and out repeatedly, and the LED stays on.
> Do you hear the drives spin at all? If not, perhaps check for 12V at the
> PSU. I don't have schematics for the system handy, but it wouldn't surprise
> me if it doesn't use +12V for the drive motors (spindle and head) and maybe
> some of the auxiliary logic (e.g. modem and RS232), but not for the 'core'
> logic - so a lack of 12V might give the symptoms you're seeing.
> If it does have +12V, make sure it's getting to the drives - my memory's
> hazy, but I think there's a little power distribution harness/board in
> these systems, so there's some potential there for faults (broken wires,
> dirty connectors etc.)
> cheers
> Jules

More information about the cctech mailing list