SPARCClassic won't boot cdrom

David Brownlee abs at
Sun Aug 2 10:14:53 CDT 2015

On 2 August 2015 03:49:47 BST, Benjamin Huntsman <BHuntsman at> wrote:
>Hi all!
>I recently acquired a SPARCclassic, which is my first bit of Sun
>hardware.  Having an awful time getting it to boot from the CD-ROM.  I
>have tried a bunch of different terminators and several different
>cables, but whenever I try to boot I get this:
>ok boot cdrom -s
>Boot device: /iommu/sbus/espdma at 4,8400000/esp at 4,8800000/sd at 6,0:d  File
>and args: -s
>The SCSI bus is hung.  Perhaps an external device is turned off.
>Any ideas as to what might be wrong here?  The thing does not seem to
>send any commands to the CD-ROM, as the LED never comes on and I don't
>hear it doing anything...

There have probably been enough replies on the CD, so I thought it might be helpful to mention some other boot options :) 

If you have a SCSI disk and controller in another device you can dd an installed system into the disk. Last I checked qemu sparc worked quite well to install onto an image (or any number of people on the list could provide a suitable disk image) 

Sparcs also netboot well, you just need  rarpd and tftpd to get a the bootloader across, after which bootp and nfsd (or bootparamd if you are very old school :). Even if you get the CD working it's nice to keep a netboot setup around. 

Alternatively if the floppy drive has not expired you can boot from that... 

Once you have an OS loaded it gives another way to test the CD

More information about the cctech mailing list