SPARCClassic won't boot cdrom

Mouse mouse at Rodents-Montreal.ORG
Sun Aug 2 07:27:45 CDT 2015

> I recently acquired a SPARCclassic, which is my first bit of Sun hardware.  $

Please don't use paragraph-length lines.

> ok boot cdrom -s
> Boot device: /iommu/sbus/espdma at 4,8400000/esp at 4,8800000/sd at 6,0:d  File and args: -s
> The SCSI bus is hung.  Perhaps an external device is turned off.

>    Any ideas as to what might be wrong here?

Perhaps the SCSI interface is fried.  Does it still exhibit the same
symptom with nothing at all plugged into the external SCSI connector?

Perhaps the external CD drive is fried.  Have you tried it on another

Given that there are only four parts involved (the Classic, the drive,
the terminator, and the cable) and you've swapped out two of them
multiple times, those strike me as the most plausible alternatives.

Do any of the terminators you've tried have power-on lights?  Most
SPARCstations have a fuse in the terminator power line, which might be
blown - though admittedly in my experience that doesn't lead to a hung
bus, especially if you're using short cables.  Can the CD drive be
switched or jumpered to provide its own termination (in which case you
should leave off the external terminator)?

>    The thing does not seem to send any commands to the CD-ROM,

It's probably issuing that message very early, likely while still
probing for device presence.

/~\ The ASCII				  Mouse
\ / Ribbon Campaign
 X  Against HTML		mouse at
/ \ Email!	     7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B

More information about the cctech mailing list