Fixing Dungeon on RSX 4.2

Chris Zach cz at
Fri May 15 18:58:49 CDT 2020

So I'm working on fixing some old code here. Found my balticon gaming 
system disks from 1990 (yes, I used to drag a pdp11 and 4 terminals to 
Balticon and other cons for computer gaming) and dungeon works on the 
4.0 RSX version I was using but when I try to run it on 4.2 I get an 
Error 4 at PC 162570.

I tried recompiling: RSXCMP works fine and compiles all the modules 
however when I run TKB with the rsxbld I get a bunch of *DIAG* Segment 
(root3, rooms, etc) has address overflow: allocation deleted.

What am I doing wrong today? The task builder file is:


Reading the docs I see:
The Fortran-IV-Plus object time library must be merged into
     the system library (SYSLIB.OLB).  Further, the library must
     be set up to invoke the short error text module ($SHORT) as
     the default.  Task building with a separate object time library
     produces numerous errors;  task building with a resident library
     or the normal error text module produces an oversize task image.

This might be the problem, anyone remember how to put the short error 
text module into syslib.olb? Hm. Maybe it is. Hm....


More information about the cctalk mailing list