Mark G Thomas Mark at Misty.com
Mon Feb 5 12:20:30 CST 2018


Please see resolution below, if you are curious about how this turned out.

On Wed, Dec 20, 2017 at 09:18:50PM -0500, Mark G Thomas via cctalk wrote:
> Hi,
> > On Wed, Dec 13, 2017 at 9:08 AM, Mark G Thomas via cctalk <
> > cctalk at classiccmp.org> wrote:
> > 
> > > Hi,
> > >
> > > I am working on several projects requiring 2708 and 2716 EPROMs, and
> > > am finding some of my chips will not erase, and some will not take
> > > a program. I've also learned more in the past week than I wanted
> > > to know about repairing Data-I/O 29a/b programmers.
> > >
> > > I vaguely remember in the 1990s baking such EPROMs in the oven, but
> > > I do not remember temperature or time. I was surprised that Google
> > > didn't turn up anything useful with this info.
> > >
> > > I'm sure someone here will have some notes on EPROM baking.
> > >
> > > Mark
> > 
> > Mark,
> > 
> > If this is an issue about reviving bad eproms?  I assume you have tried the
> > regular stuff.
> > 
> > What process are you using now to erase 2708/16's?  I have a simple eraser
> > unit and it seems to always work.  Some eproms go bad but I never have
> > issues with erasing them.  My point is that maybe you need a better prom
> > eraser unit.  
> They seem to erase fine, using a PRO-LOG 9103 eraser (box, timer, tube...)
> > I would avoid baking them until you have exhausted other
> > options.  Not sure what others think.  This topic has come up before here,
> > about putting them outside and all that.  The erasers are all over ebay,
> > and the hardware store is full of the correct types of lighting, why not
> > make a box that will do the job?    I assume there is more to it that
> > simply erasing them.
> > 
> > 
> > Bill

After more experimentation I came to the following conclusions.

1) Some of my chips are legitimately bad, erasing fine but won't take a program.

2) Many of the chips were failing to program because my Batronix 
   programmer apparently requires more current than my USB port provides. 
   This surprised me because I have been programming chips for years 
   using this programmer on this computer port successfully, and this 
   is the first I have had the problem. Using a Anker powered USB hub solved
   things. My Batronix programmer even arrived with a cheap powered hub 
   when I ordered it, but I never used it because it was shipped with an 
   incompatible wall wart, but looking at it in the box gave me the idea
   that this might be the issue.

3) I thought I had ruled out the programmer (#2) because of troubles 
   programming those same chips using another programmer, but I probably 
   had the wrong chip type selected, or simply failed on some of the #1 
   chips so assumed that was my only problem.


Mark G. Thomas (Mark at Misty.com), KC3DRE

More information about the cctalk mailing list