wonky eproms

Mark G Thomas Mark at misty.com
Sun Feb 4 12:22:38 CST 2018


This might seem stupid, but I recently had peculiar results with a usb-powered programmer failing on certain ranges of addresses on certain chips, that turned out to be inadequate current available on my USB port. For me, a high-current powered USB hub solved it. I programmed a huge number of chips successfully before I ran into this problem with a particular batch of chips.


Mark G Thomas

> On Feb 4, 2018, at 9:40 AM, David Griffith via cctalk <cctalk at classiccmp.org> wrote:
> I have a few tubes of ST-branded M27C256B UV-erasable EPROM chips.  All of these fail to program starting at 0x200 until 0x27F.  At 0x200, 0x00 is written, then until 0x27F, the bytes are 0xFF.  What would cause this? Can it be fixed by an extra-long time in the eraser?  Should I just break out the hammer?
> At least I know the programmer is capable of programming a TI-branded 27c256 and 29c256 flash chips.  Might there be a bug in the programming software?
> FWIW, I'm using a Minipro TL855.  Linux software is available at Github: https://github.com/vdudouyt/minipro
> -- 
> David Griffith
> dave at 661.org
> A: Because it fouls the order in which people normally read text.
> Q: Why is top-posting such a bad thing?
> A: Top-posting.
> Q: What is the most annoying thing in e-mail?

More information about the cctalk mailing list