SIM990/DX10 help?

Sean Caron scaron at
Sun Jan 4 10:32:35 CST 2015

Hi everyone,

I downloaded Dave Pitts' SIM990 emulator and the pre-rolled DX10 disk
images available on his site yesterday evening, thinking I'd give it a run.

SIM990 compiled clean; I'm running on Debian 7.7, 32-bit, on an Intel D510
Atom system.

I feel as though this should be plenty of power... I run Hercules on this
same system all the time to fool around with MTS and MVS 3.8J and I find
the performance to be just fine... (way better than on my old Sun Fire
V120s, LOL)

I extracted the DX10 images and I started the emulator on them as directed:

sim990 -msc 12 512K dx10.cfg

For a terminal emulator, I'm using PuTTY; I also tried Procomm Plus (latest
version) with a few different emulations and couldn't make it work, I seem
to get furthest with PuTTY.

I connect using Telnet protocol to port 2000 on the emulation host. I get
the DX10 IPL screen:


I hit F10 then "!" and I get a sort of menu-like thing:

DX10 3.7.0



I don't get a signon prompt but I assume user login has not been enabled on
this basic disk image, however...

I never get the SCI prompt, [], and it seems unresponsive; I've tried
typing i.e. BASIC, COBOL, commands from the DX10 manual, totally random
junk, etc. and I don't get any response; I mean, it seems to be refreshing
the screen every time I hit RETURN; it's not giving me any kind of error
message, but it's not really doing anything either.

Is my emulation just not working right? I tried the DNOS image too and I
was able to get a little further... At IPL it prompts for date and time
which I'm able to fill in, and there is a login stage (l: SYSTEM, p:
SYSTEM) which I can get through, just use the cursor keys to move through
the fields and hit RETURN to push the screen (it seems screen-oriented,
feels reminiscent of an IBM) but once that's done I land at an equally
unresponsive main menu just like I describe occurring with DX10.

Has anyone played with this and found a Telnet client that works well? I
don't see anything on the author's site other than to note that Windows
Telnet won't work. Not clear what I'm doing wrong.



More information about the cctalk mailing list