Interesting drive failure...

Josh Dersch derschjo at
Wed Apr 22 00:54:42 CDT 2015

I'm attempting to dump an image of the Ridge 32/330's original SMD drive 
(A Fujitsu MK2322) -- I'd been running it off of a spare, because I 
didn't want to disturb what was on the original drive until I could back 
it up.  Now that the spare has died I figured it would be an opportune 

The Ridge "DISCUTIL" tool (loaded from QIC) is pretty powerful, and 
amongst its weapons is the "DS" command which will dump a sector of the 
disk to screen, in ASCII HEX.  The Ridge has been running for the past 
eight days dumping the entire 168mb disk, in HEX, at 9600 baud.  Yes, 
I'm insane.

Along the way I discovered that the integrity of the data on the disk is 
pretty poor.  There are lots of bad sectors.  In particular surfaces 2 
and 3 are completely unreadable for all 823 cylinders, surfaces 4 and 8 
are marginal most of the time.  After a lot of retries I've managed to 
get most of everything (except for surfaces 2 and 3 which yield no data 
at all).

So I figured that heads 2 and 3 are toast -- perhaps bad analog logic, 
maybe something in the digital logic that selects the head, maybe even 
bad heads, who knows.

DISCUTIL also has a "FORMAT" command that will format individual 
cylinders, on a specified surface.  So after I'd read out everything 
possible to save, I tried it on a cylinder (801) known to have trouble 
sectors, that also containing all zeros so I wouldn't wipe out anything 
vital.  After doing a format on cyl 801, head 2 I could read all sectors 
on that cylinder/head without issue.  Same with head 3, 4 and 8.  
Suspecting a possible addressing fault I tried reading every surface on 
cylinder 801 after formatting all surfaces on that cylinder, and they 
all read without issue.  (I'd expect that if, for example, when I asked 
the disk to format surface 2 it actually formatted surface 5, then 
reading surface 5 later would fail due to an invalid sector header for 
surface 5...)

So, I suppose this is somewhat good news in that I may be able to use 
the drive, but I wonder what would cause the data on the disk to fail in 
such a manner (and I'm still hesitant to reformat the drive without 
recovering stuff off of surfaces 2/3...)  Any thoughts?

- Josh

More information about the cctalk mailing list